1Password Beta 8 No Longer Responding To Any Triggers

I wrote the below macro to automatically start 1Password as well as load a specific webpage.

It worked perfectly yesterday.

It no longer works today. It fails to activate 1Password at all!

The only thing I did between yesterday and today we reboot my laptop.

Would appreciate some input as all looks good to me.


Start 1Password.kmmacros (58 KB)

When you say it "fails to activate," do you mean it actually generates an error message? Or do you mean it skips that statement and goes directly to the next statement?

The activate command does nothing, not one thing!

That still doesn't tell me the answer to my question, which is does the remainder of the macro continue to function? I'm not asking about the Activate action, I'm talking about the rest of the macro.

Hmm, I do not know as I have not tried anything else...that said, 1Password, does respond to Window Move and Resize Commands.


It looks like 1Password, for whatever reason, doesn't respond to the Activate Application action as it should, but it does seem to work with the Open a File, Folder, or Application action:

Let me rephrase my question in a totally different way. If you open the debugger, and check "Pause new macros", and step through your macro as it runs, does the debugger run the actions that follow the first action in your macro.

However now that GG has made his observation, I think the answer is probably yes, so you can ignore my question now.

It's an Electron app.

I've seen this before a time or two.

That may be it, but personally, I've never had any trouble using the Activate Specific Application action with the Electron-based Slack and Discord, and at least on my system, activating 1Password with the action seemed to fail in the same way with the native version 7.

Appreciate that, I will try it using the open with Finder!

Weird, but if it works then so be it.

I have never heard of an Electron app, what is that?

As always, thank you.

I am learning so much here!

1 Like

Interesting... Activating 1Password 7 here on my Mojave system fails with the Keyboard Maestro action every time.

I resorted to the shell which works every time:

open -b com.agilebits.onepassword7

I hadn't noticed this, because I always launch 1Password with LaunchBar.

Good to know it is NOT me!