8.0.5 update glitch

I ran the "8.0.5" update and it did not complete. The computer completely "hung" and I was forced to do a forced shutdown. After restarting KM did not automatically launch. Attempting to launch KM resulted in this Finder message:
image

Should I drag it from the trash and try the update again?

Disclaimer, I have been having unusual system "beachballs" since running the most recent "El Capitan" security update (10.11.6). Don't know if it related.

Update:
There are actually several versions of KM in the trash:
image

Would I drag out the one referenced in the error message?

Another update:
I took a chance and retrieved the reference KM app from the trash, launched and re-ran the updated. Worked like a charm.

I haven’t heard of any other update issues, and nothing in the update system has changed in a while. My guess in that the computer ran into other problems during the update and that caused the update to fail.

You can always download a clean replacement application from our archive site at:

https://files.stairways.com/

Replacing the application will not affect your macros (assuming it is the same or similar version you are replacing - going to a much earlier or much later version can sometimes affect your macros).