A Macro Doesn't Respond to a Keyboard Shortcut - Everything Is Enabled

I already replied in another thread with the suggestion to simply enable the macro group to which the macro belonged and thought the problem is gone but I was wrong. Just now, I created a macro which is a simple AppleScript script and assigned a very large key combination (that would guarantee no app uses it) but no matter what it doesn't launch the macro. The shortcut is ⌃⌥⇧⌘P. I then put that script inside an Automator service and assigned this shortcut to the service in Services preferences which worked. It doesn't even run in the Editor. What gives?

I have to add that every time I press the keys the corresponding entry is created in the KM log acknowledging the keypress without any record of errors. On top of that its KM 5 but strangely, I notice this fault in every version from time to time, though still way more often than I would expect.

The script lets you make a quick screen recording without launching QuickTime Player manually then provides you with choices of which the default ones is to save the exported movie to "Movies".

I upload the macro which installs itself as a library (Application Control). Does it kick the trigger off? If not try to create an Automator service (receives input in any application) and launch with this or any other shortcut you choose. Does it make a difference?

Make A Quick Screen Recording.kmlibrary (8.0 KB)


There's nowhere near "50 macros" under "All Macros". What's with "aborting everything"?

Update December 9, 2020 4:10 AM

I then changed the trigger type to "device key" and assigned the same shortcut ("Keystroke P with modifiers ⌃⌥⇧⌘"). First it worked and was consistent but only until I rebooted. After that, it stopped responding and I got back to square 1.

can you post the macro as image to get an idea?

Forgot to mention that it doesn't launch from KM Editor with "Try".

The solution is this post from another thread, the link is below. The root of the problem was that KM is incapable of running user interaction events (display dialog, choose from list etc.) on its own in AppleScript and Java-AppleScript Bridge scripts unless you put any such statements in a frontmost application context. I was able to catch this error by selecting the show result in a window option of the Execute AppleScript script action.

No user interaction allowed (error -1713).