Activate Clipboard History Switcher : Long delay

Since the last few week I can't really use Keyboard Maestro as a clipboard manager, as It's took a good 10secondes delay before displaying the windows.

Tried with the keystroke but also with the "try" button, it's always super slow.

Any idea how to fix it?

Thanks in advance

As a test, you could do

defaults write com.stairways.keyboardmaestro.engine MaxClipboardHistory -int 20

to see whether it speeds back up.

This probably means you have either a few very large clipboards, or a lot of just large clipboards, or very many clipboards.

I have not seen this behavior in KM9, but I did in KM8.

One easy solution is to clear all clipboards if you don't need any of them.
Else, go through the clipboards and delete the big ones you don't need.

If you have any large Clipboards that you need long term, I would copy them to Named Clipboards and then delete from Clipboard History.

Finally, you can reduce the number of Clipboards you save in the Clipboard History
See Clipboard Hidden Preferences.