Alt-q key behavior since upgrade to Mojave not working

I have a macro assigned to the alt-q key in Keyboard Maestro for years that copies text, removes formatting, wraps it and places a "> " in front of each line. I use this constantly to quote sections of a mail message I respond to. I've always assigned the macro to the "alt-q" character combination.

I recently upgraded to Mojave (OS 10.14.6) and, for some reason, the alt-q is not assigned to the macro and only prints the œ character, I checked to make sure my keyboard is not masking this key combination. I am using a standard Apple keyboard and it has not changed. I tried re-assigning the macro to a different key combination and it still doesn't seem to work. The normal paste key "command-v" does execute the macro without my assigning it to it - for some reason. Has anyone else experienced a keyboard mapping issue like this in Mojave? Thank you for any insight anyone might have...I'm a bit of a loss as to what to try to correct it!


If you just upgraded to Mojave, then chances are the Mojave accessibility bug is affecting you. Resolve it as described at: Accessibility Permission Problem.

Failing that, use the interactive help (Help ➤ Interactive Help), and select Something expected is not happening and follow the instructions.

Hi Peter,

Thank you, once again, for your help resolving my (and so many others) issue ! I read your series of suggestions concerning the Accessibility Permission Problem as I was debugging my issue and carefully proceeded through each step. I was puzzled by the fact that after the entire process, my macro was still simply typing the alt-q character in lieu of executing the macro. Another few debugging sessions finally resolved my problem - and I am to blame! Apparently, during the process of changing the character sequence to enable the macro, I had accidentally typed an "alt-q" at the end of the series of macro steps. Hence, whenever I ran the macro, it executed and then replaced the clipboard it was supposed to paste with the "alt-q" character. Please know that after correcting the macro by removing the added step, it is now working as expected in Mojave. I may have experienced the accessibility issue initially, but I managed somehow to corrupt my macro after that did not notice.

Thank you, again. My apologies for wasting your time!

1 Like