"Always Hide" on Application Switcher not turning off

Hi all,

Whenever I bring up the Application Switcher and choose an application, all others get hidden. “Always Hide Other Applications” in the KM General preferences is deselected. I have tried restarting the KM engine as well as rebooting. I’m running KM 6. Thanks for any suggestions!

Paul

Hey Paul,

What’s your keyboard shortcut for the app-switcher?

-Chris

Hi Chris, it is Command-Tab

Hey Paul,

Hmm… Unless you have another utility installed that might be interfering with Keyboard Maestro I’m out of ideas.

-Chris

None that I’m aware of, Chris. Thanks for taking a stab at it!

In the Switcher Group, in the Activate Application Switcher macro, in the action, there is a configuration for “Hide other applications when switching”. It sounds like you have accidentally turned that on at some point.

Hi @peternlewis. No, I think I have it turned off properly:

No, not the global preference, the preference in the Application Switcher action.

1 Like

Ah yes, now I see, @peternlewis! That’s cool, because now I can define a regular switcher as well as a hiding-switcher, each activated by different keystrokes. Thanks!

Hey Paul,

The KM app-switcher has some hidden features. See the wiki:

https://wiki.keyboardmaestro.com/action/Activate_Application_Switcher

• Press “d” to switch directly to the current app and hide other applications.

OSX also allows the Cmd-Opt-H hotkey to hide apps other than the front one.

-Chris