Avoiding Processing Escaped Text When Inserting by Pasting, In Variables, Etcetera

I have a snippet of text stored in KM which I'd like to paste into an application. The text, on screen, in the text box for "Insert text by pasting", reads:


However, for reasons that are unclear, KM sees this text internally differently and when it pastes, it does so as:


When I say "internally" what I mean is if that if I assign the same text snippet to a variable, I can see within KM that the variable's definition is the wrong text, not what I've actually defined.

I've also tried Inserting text by typing, and inserting stylised text with no better result.

Feels like a potential glitch. Any suggestions on how to get my required text to paste from KM?

Hey @dotsplatslash,

In future when asking for help please post the simplest possible test macro that properly demonstrates your issue, so we can test your actual work verbatim. You're more likely to get timely and useful help when you make it easy.

You're running afoul of Keyboard Maestro's normal text processing.

For this specific issue you can just select “Process Text Tokens Only”:


Note that this setting shows up in a number of Keyboard Maestro actions.

Take Care,

(Keyboard Maestro Moderator)

Outstanding, completely overlooked that option - and in all my years of using Keyboard Maestro, it's taken until now to run into the issue. Thank you!

1 Like