Cannot figure out how to get KBM to access the following like (a document within a file)

Each Scrivener file is basically a Binder containing multiple documents.. I repeat: each file contains multiple documents, each of which has a link which can be copied.
each document has a link, for example, here is a link to one specific document within my todo Scrivener file.
If I paste this link in a Pages document (I am just using Pages as an example. I could paste it anywhere), and I click on the link, I go directly to the document within the the scrivener file which contains it, which means that Pages understands the link syntax.
I tried all kind of KBM actions to try to create a macro which would navigate directly to the document, but nothing works. KBM does not recognize the link syntax as valid.
Would someone have a suggestion?
thanks very much for your time and help

This works for me:

(Personal destination obfuscated in the image.)

What errors are you receiving that indicate the syntax is invalid?

1 Like

If you insert the x-scrivener-item URL via clipboard, like this, then it works:

See also:

1 Like

Or, better: just disable the Processing options of the Open URL action:

1 Like

I just plugged in the x-scrivener-item URL and it worked in the URL action -- no need to adjust options.

If a custom URL is not working, it can be helpful to fix the URL-app assignment in Default Apps

(YMMV -- I understand that Default Apps is not working for some folks in Sierra.)

1 Like

No, I’ve seen the same “invalid URL” error as probably ronald:

With “Processing Nothing” it seems to work.

My URI scheme seems to be OK, according to RCDefault app.

1 Like

You can also check via Terminal:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -dump | grep scrivener
1 Like

It seems it depends on the URL: If there are only ASCII characters in the path then the Processing options don’t matter. With non-ASCII chars in the path I have to set the action to “Process Nothing”.


Good analysis.

1 Like

…but I’ve just seen that @ronald’s URL doesn’t contain non-ASCII chars. So the URL action should work for him with or without Processing… :thinking:

1 Like

@Tom @korm
Thank you very much Tom and Korn. it works when i process nothing.