Cannot run macro by bash script [solved]

im running version 8.0.4 and im trying to run a script via bash.

Ive enabled shell script

and when i try to run it, im getting this error

➜  ~ osascript -e 'tell application "Keyboard Maestro Engine" to do script "DC4D8338-2F05-43F0-8377-C0C58125E191"'
46:94: execution error: Keyboard Maestro Engine got an error: do script found no macros with a matching name (-1)

Does anyone know if this is a known issue or im missing something massive ?


Note to self, google first, post later.

I was able to work my way around it using the assistance menu.

The problem was that the group was not active, although i configured it to be active always

When i moved it to Global Macro Group, it worked.

Based on your screenshot of the macro group setup, it should be active. If not, then you may have set the group inactive in another macro?

To make sure it is active, you can do either of the following:

  1. Restart the Keyboard Maestro Engine
  2. Run a macro with the Activate Macro Group Action.