Can't Sync Macros on New M3 Max MacBook Pro

I'm setting up a new M3 Max MacBook Pro. I installed Keyboard Maestro. It loaded fine. When I select Preferences > Sync Macros > Open Existing ..., I get a message that says, “This Will Replace All Your Macros.” I click on Replace All Macros, and then nothing happens. KM hangs with the spinning beachball. In a few minutes, it stops but without giving me the option to choose a sync file.

How can I fix this? I've tried rebooting and uninstalling and reinstalling KM.

I'm running KM 11.0.1 on macOS 14.1.1. on a brand new M3 Max MacBook Pro.

This is what I show in Activity Monitor:

I tried reinstalling macOS, but that didn't help. Also, every file dialog in KM seems to be affected, including all the file import and export options. I can't use any of them.

Also, I tried re-booting into safe mode. That didn't work either.

Okay, I fugured itr out—sort of. Apparently, there's some kind of software conflict. I created a new user account, loaded KM first, and it worked fine. IfI had to guess, I think it's likely a conflict with Google Drive. We'll see.

1 Like

Sounds like Keyboard Maestro is simply unable to read the file for some reason.

Since it is the Open and Save Panel Service it seems likely the issue is happening before it even gets back, to Keyboard Maestro.