Command option hot key and Komodo Edit

This is just totally strange. I have a macro which starts Komodo Edit via the Activate action. If I invoke the macro from the status menu, all is well - Komodo Edit starts, and the left pane display the Places and current project, just as it should. If I invoke the macro via the hot key (option-command-k), then Komodo Edit opens, but the left pane is empty! Changing the hotkey to ctrl-command-k makes everything ok again … but it appears that any hotkey using option-command-(any key) causes problems. I haven’t tried every possible combination, but I’ve tried several.

All of my other macros which launch applications have hot keys using option-command-(some key), and they all work fine.


KM 7.0.1, OS X 10.11.1, Komodo Edit 7.1.3, build 11027, running on a iMac (27 inch, late 2013) w/ 8GB memory.

Am I missing something incredibly obvious here?

Hey Larry,

Try launching Komodo Edit from the Finder with Cmd-Option held down.

See if its launch behavior changes.


So, it depends on exactly what you mean by “launching from Finder”. If I
start it from the dock, Cmd-Option has the same bad effect on Komodo
Edit as using a Cmd-Option hotkey with KM … and in addition, it hides
all the windows of all other running applications. If instead I navigate
to the Applications folder in a Finder window and double-click on Komodo with Cmd-Option, Komodo starts correctly, but the Finder window
is closed (not hidden).

ccstone wrote:

Just another data point … if I right-click on Komodo Edit while
viewing the .app in a Finder window, and then select Open from the
context menu while holding down Cmd-Option, Komodo opens correctly and
the Finder window is neither closed nor hidden.

Larry Azlin
Sent with Postbox

Larry Azlin wrote:

Hey Larry,

Hmm. I don’t use Komodo, so I can’t readily test this.

You might look through the troubleshooting guide on the wiki.

I don’t think you’ll find anything for this particular problem, but it’s a place to start.

Make sure you quit and restart the Keyboard Maestro engine.

You could reboot just for giggles.

As a test you could install FastScripts.

Create an AppleScript with the Script

tell application id "com.activestate.KomodoEdit"
end tell

Install here:


Give it the same keyboard shortcut in the FastScripts prefs. (Hold down the key when selecting the script from the FastScripts menu to assign the key.

If you get the same behavior from FastScripts then the problem isn’t Keyboard Maestro.

If you get normal behavior from FastScripts then write up a bug report with before/after screenshots of expected behavior and aberrant behavior. Send that to Peter directly.

See the support address:


Hi Chris,

I tried it with FastScripts, and it exhibits the same problem when
activated with Cmd-Option-K, so I guess this isn’t a KM issue.

Thanks for your suggestions about how to clarify this situation! Guess
I’ll just launch it from the KM menu bar menu when I need it…

Larry Azlin
Sent with Postbox

ccstone wrote:

Hey Larry,

I’d report this to the Komodo people and find out if it’s a bug or a feature.


Add to the front of your macro a Pause Until Modifiers Command and Option released. That way you press Command-Option-K, and then the macro just waits for you to release the modifiers and then continues.

Perfect! All’s well with the world (or my little slice of it) once
again. Thanks!