CreateMacro no response to typing hotkey

I’m completely new to this. The instructions say create new macro, choose hotkey type, type the hotkey (example provided was ^-M)

I can type keys until the cows come hoe because none of them elicit a response from the UI.

This is on Sierra.

Can’t use the app if I can’t define a hotkey.

Please help

The shortcut keys don't contain a dash i.e. "^M" not "^-M", see the image below.

Becomes this :slight_smile:

In addition, the same actions apply when you are assigning a hotkey trigger in a macro

Click in the box, hold down your modifier keys and type a key on the keyboard.

I strongly recommend running the interactive tutorial (Help->Tutorial).

The sequence of steps that I followed came directly from the tutorial. It said there would be a blue box labeled ‘type’ and that I should press a key. I tried practically every key on the keyboard but got no response to any of them.

Do think if I repeat the exercise a fifth time I will get a different result?


1 Like

ok, here’s what I did. Where did I screw up?

I’m not sure, but I can assure you that creating a macro and assigning a hot key works very well. I have never had it fail, and have never seen anyone else report this issue.

Perhaps this short video will help you:

Apparently it is not allowed to press the hotkey until the macro has a
name. duh...

Anyway, I have created the 5 macros that I want. They worked once I got
the actions enables (not sure why some are enabled by default and others
are not).
Then I logged off and on again. Since then none of them work even
thought they are all "active' when examined in the editor. See attached.

I'm confused by this. There must be some other secret step that I have
yet to discover. Perhaps you can enlighten me.


Global Macro Group Macros.kmmacros (6.11 KB)

I looked at your macros, and they look just fine.

Here’s the thing: You describe having some of the actions not be enabled by default, and I’ve never heard of that. In fact, I don’t think it’s possible to add an action that starts out in the disabled state.

Don’t get me wrong - I’m not calling you a liar, but I wonder if what you think is happening isn’t actually what’s happening (I hope that makes sense). I know I do that all the time - draw the wrong conclusion from a series of events, or perhaps just describe the situation using the wrong terms.

Is there any way you can make a screen recording to show the issue? Or describe, in exact detail, the steps you take to produce this issue? Other than that, I don’t know what to suggest. Perhaps some others will have some ideas.

If you duplicate a disabled macro, the copy is disabled by default. That’s the only way I can think of doing it.

Right, but he talked about Actions not being enabled, not macros. I’d love to look over his shoulder while he’s working. :slight_smile:

Well, here’s what I did. I created a macro, added an action, clicked the
gear on the action. The popup list said ‘enable’ so I did. The I logged
off, logged back on, went to view the action in the editor and the popup
list again offered ‘enable’. In another macro I created the action was
enabled by default.

Also, I’ve created the 5 macros I attached earlier. The ones for f13,
f14 an f15 work now but the ones for Home and End on my pc-style
keyboard don’t. the Apple Keyboard flashes the correct key when I press
those keys but the action is not carried out.

My only excuse for anything I’m doing wrong is that I flunked Mind
Reading 101 and the docs provide very little insight into what might go
wrong or how to fix it.

To answer the question about duplicated macros, I didn’t duplicate any
macros, disabled or otherwise.

My problem is undoubtedly one of inexperience. I’ve only been
programming since 1967, got my first PC the month that they came out
with the 10mb hard drive and my first Mac was the Classic with the
floppy drive.

In general I do better with command-line interfaces and Gui front-end
than I do with language interpreter interfaces like on the Apple II,
MUMPS, LISP, etc. I’m also not wild about environments like small talk
whee all changes alter the system state. They are hard to deploy and
difficult to integrate with other apps.

I find that some apps and interfaces just work like I imagine they
ought. Others leave parts undocumented, probably because they are
’obvious’ to the developer and long-time users, but, as I said I’m a
failure as a mind reader so some of my mistakes must seem pretty dumb.

I’ve only been programming since 1972, so you got me beat. My first PC was the original first edition, with a floppy drive (or perhaps 2? hard to remember). But it did have the color monitor! Unfortunately, I’m late to the Mac game - got my first Mac in 2008.

It sounds like you’re having the same issues I did when I first got KM. Except in my case, I got so frustrated that I quit trying to use it for 6 months, then tried again. KM is not like any application I’ve ever used, and it’s especially frustrating since I’m a developer.

All I can say is, once I got past the initial hurdle, it has been so totally worth it. As a developer, the things I can do with this have been amazing.

As to your problem with the macros not working, I can think of some possible reasons:

  1. You have another application, such as Karabiner, or a keyboard driver, or something, that is affecting the keystrokes somehow.
  2. You have the output keystroke mapped to something else, in KM.
  3. It actually is working, and output keystroke doesn’t do what you think it should do.

One other thing. I feel your pain - I really do. I may be projecting here, but reading your posts, I feel like I’m reading something I could have written myself. For example, when I was trying to learn JavaScript for Automation a few months back, my level of frustration hit 10, because I just couldn’t find answers to my questions like I felt I should be able to.

I hope you don’t give up with KM. I promise you that if you manage to get past your initial frustration, you’ll be totally glad you did. But I 100% understand if you give up, too, as I did initially.

As an enticement to the developer in you, let me just say that there’s all sorts of fun you can have “under the hood”, once you get past the admittedly steep learning curve. :slight_smile:

I’m happy to keep at it. I’m addicted to my clicky PC keyboard. Most of UI design features that I believe Apple has misunderstood have been corrected over the years (such as no longer being limited to resizing a windows at the lower right corner). Two that remain are single keystrokes for beginning and end of line.

To get this behavior I need to remap Home and End to command-left arrow and command-right arrow. I have created a macro for each with the corresponding action but they don’t produce any detectable effect.

If you can help me get over this hump then I will be ready to explore the other, really intriguing features of KM.


re: As to your problem with the macros not working, I can think of some possible reasons:
You have another application, such as Karabiner, or a keyboard driver, or something, that is affecting the keystrokes somehow.
Karabiner did what I need but doesn’t work on Sierra. It’s been removed. The beta of karabiner-elements won’t do keystroke combinations and it doesn’t work as a service. It interferes with KM when running but not after it exits.
You have the output keystroke mapped to something else, in KM.
I only have the 5 mappings I sent plus whatever came with the install.
It actually is working, and output keystroke doesn’t do what you think it should do.As to your problem with the macros not working, I can think of some possible reason.
cmd-left and cmd-right work as expected and what the actions are set to send (I think). I did’t read every line of the exported macros so maybe they are not right but these are net terribly difficult substitutions in theory. The macros do seem to swallow the home and end keys as the no longer move to the beginning and end of the document.

Does any of this help?

I dug out a stock Dell keyboard to test your macros with and they all worked as you intended. Out of curiosity what kind of keyboard are you using?

I have macros just like you're talking about. They work fine for me. Here's some of what I have. See if they shed any light or not.

__Keyboard Remapping Macros.kmmacros (20.9 KB)

The keyboard is a Unicomp UB40PGA. I’ve also tried it with the Apple
extended keyboard and a Dell keyboard. All do the same thing which is:
Home scrolls to the top of the document but does not reposition the
cursor and End scrolls to the bottom of the document but does not
reposition the cursor.

The machine is a Mac Pro, for whatever that’s worth.

Out of curiosity I tried to remap command-Home to command-left arrow
(although this defeats the goal of haveing a single keystroke). With
that set all I get is a beep.

I’m attaching a video. You will note that I actually got my mapping
reversed in this example but the point is that it doesn’t do anything at
all, not that the mapping is backwards.