CreateMacro no response to typing hotkey

Thanks. While I look at that, this works (from StackExchange):

|$ mkdir -p ~/Library/KeyBindings |

Then create or edit the file
at|~/Library/KeyBindings/DefaultKeyBinding.dict|. If it didn’t exist
before, add the whole section below. If it does exist, just add the four
new rows inside the block.

|{ “\UF729” = “moveToBeginningOfLine:”; “\UF72B” = “moveToEndOfLine:”; }|

1 Like

Your macros, and mine, both work in Word but neither works in
MultiMarkdown Composer or TextEdit.

sOn 9/26/16 10:58 AM, Dan Thomas wrote:

Right. That just means that those apps use different key combinations. Figure out what they need. You can see in my macros that I have some that do different things depending on the apps that are running.

By the way, I have the Apple Extended (wired) keyboard.

What you describe indicates a problem along the lines of:

  • The system not granting Keyboard Maestro and Keyboard Maestro Engine accessibility.
  • The system being in Secure Input Mode.
  • Keyboard Maestro Engine not running.
  • Keyboard Maestro and Keyboard Maestro Engine not able to communicate.

To start with, restart. This will resolve the system being stuck in Secure Input Mode, and will often also resolve issues with accessibility permissions (which macOS has been notoriously flaky about!), it will also likely resolve Keyboard Maestro Engine not running and any communication issues.

So while I don’t generally recommend jumping towards “Restart” as a solution, in this case, it is the quickest and easiest way.

If the issue repeats, then you have to delver deeper.

Note especially in my experience in recent years, any time you do any system upgrade (even a minor one), restarting a second time is highly recommended.

Hi Peter,

I haven’t had a chance to do this yet but i will as soon as I deactivate
DefaultKryBibdibgs and restart.


I thought the best thing might be to try it on a different machine so I
installed it on my Macbook Air with Yosemite. No other keyboard apps

I remapped Home, End, Mute, Volume Up and Volume Down.

Home and End to BOL and EOL work (they don’t on the Mac Pro)
Mute mapped to F13 works
Volume controls mapped to F14 and F15 are weird. See attached video.

I have no idea what’s going on - still.


Man, you are having trouble. :slight_smile: I hate when that happens - when I seem to be the only person with certain issues, Makes me want to break my keyboard or something. :rage:

With what you described, it sure sounds like you’ve got something that remaps keys on the Mac Pro. Do you agree this might be possible, or did I misunderstand what you’re saying? I don’t remember, but if you haven’t checked System Properties, remember that you can remap some keys there, if I’m not mistaken.

When you say the volume controls don’t work, which actions have you tried?

There’s no attached video, by the way. You can’t upload videos to this forum, so put it on YouTube or something and include the URL here.


First, I’ll try attaching the video again. I think I know why it didn’t
go through the last time.

Second, at the moment, I have several keys on the Mac Pro remapped with
DefaultKeyBinding.dict and I haven’t had a change to undo that. That’s
why I decided to conduct the next test on the Air, since it doesn’t have
any mods installed other than KM.




True one of these:

By the way, when you want to add an action, I prefer Ctrl+Cmd+A, which equates to Edit->Insert Action->By Name. If you do this then type in "volume", you'll see a bunch of different options.


I tried Increase System Sound Volume. It triggers both Brightness Up and
Volume Up just like the original mapping.

I tried Increase Current Movie Volume by 10%. It triggers only
Brightness Up.

When I get back to the Mac Pro I will try these again. They are quite
irrelevant on the Air because I rarely use it with an external keyboard.


Does it do that on both computers, or just the one?

Don’t know until I get home.

Did you try some other hotkeys? Maybe those have conflicts. Try something totally different, like Control+Option+Command+V, or something strange.

Try the application mentioned here:

Sounds like it might help diagnose the problem.


I'm back on the Mac Pro with the Unicomp PC Keyboard. have remove all
remapping-related stuff except KM.

I have created the attached macros.

and I have run KeyCode:
Key Down
Characters: 
Unicode: 63273 / 0xf729
Keys: :arrow_upper_left:
Key Code: 115 / 0x73
Modifiers: 8388864 / 0x800100 ⓘ

Key Up
Characters: 
Unicode: 63273 / 0xf729
Keys: :arrow_upper_left:
Key Code: 115 / 0x73
Modifiers: 8388864 / 0x800100 ⓘ

Key Down
Characters: 
Unicode: 63275 / 0xf72b
Keys: :arrow_lower_right:
Key Code: 119 / 0x77
Modifiers: 8388864 / 0x800100 ⓘ

Key Up
Characters: 
Unicode: 63275 / 0xf72b
Keys: :arrow_lower_right:
Key Code: 119 / 0x77
Modifiers: 8388864 / 0x800100 ⓘ

KeyCode apparently cannot trap the F13, 14, or 15 keys on the Mac Pro.

Pressing home brings the beginning of the document into view but does
not reposition the cursor. Pressing End brings the end of the document
into view but does not reposition the cursor.

On the Air with an HP keyboard connected. the Home and End remappings
worked as expected but the F14 and F15 mappings triggered both
brightness Up/Volume up and brightness down/volume down.

Both sets of behavior are not what one would expect.

btw, the Mac Keyboard Identifier app that runs when I plug in these
keyboards is unable to identify either of them. It used to be able
recognize these keyboards when I was running on Yosemite.


__Keyboard Remapping Macros.kmmacros (20.9 KB)

Also, on the Mac Pro, remapping F13-15 to control the voluume works fine.

Does anyone have any additional thoughts on this?.
I’m dead in the water until a solution is available.

Thank you

In the System Preferences, Keyboard, Shortcuts, Display preferences, there are settings for Increase/Decrease Brightness.

On my Mac, they are disabled, however on my Mac, with them disabled, if I press Control-F14/Control-F15 with Sierra it does the brightness up/down regardless.

Maybe it is a Sierra bug, I have no idea.