Editor window starts on login

Every time I boot Macos the Keyboard Maestro editor window opens on desktop. I'm trying the program, but don't want to use the editor when I boot computer. Thanks

You probably have to remove it from the start items in the system preferences and in Keyboard Maestro preferences check launch engine at start.

Thanks, I ended up unchecking the start at login from the Keyboard Maestro preferences, then adding start at login in the Macos preferences, then checking the "Hide" box.

Generally, it is best to have the "Keyboard Maestro Engine" in the Login Items, but NOT "Keyboard Maestro" (which is the editor app), like this:

image

You don't need to Hide the KM Engine, as it does not have a UI (except for the Apple Menu bar).

You need the KM Engine running immediately so that any Macro you have previously built will be available to be triggered.

This is not generally what you want.

Remove any entry for Keyboard Maestro or Keyboard Maestro Engine from the Login Items, and then enable “Launch Engine at Login” (which will put the Keyboard Maestro Engine back in there).

You generally want the Keyboard Maestro Engine to launch at login, but not the Keyboard Maestro application itself.

3 Likes

Thanks for confirming. :wink: