Enable/Disable Macro Group Re-Enables Group After Reboot

I have a set of macro's that i toggle on and off using another macro that uses the action "Activate/De-Activate Macro Group".
But when i restart my computer the macro group(s) is (are) enabled again, even if it (they) where disabled when i powered down my computer.
Of course i could make another macro that disables these group(s) at Engine Launch, but is there a way to keep the macro's in the enable/disabled state when engine quits?

1 Like

Hey @Fokke,

What version of macOS?

What version of Keyboard Maestro?

Keyboard Maestro should definitely NOT be changing your settings without your permission.

Is it possible that you have a macro that's doing this?


High Sierra and the latest KM; 9.2

I don't need to reboot to make this bug happen, just quitting and restarting the Engine will make this bug happen too.

No, there is no macro installed that Activates this group. When i first made these four groups i already encountered the bug.

Well, that's highly frustrating...

I don't recall seeing anything similar on my system.

What are the names of the groups? I'll try to recreate the problem.


Ah, it is slightly different. excuse me
I confuse enable and disable groups with activate and de-activate groups.

At engine start macro groups are re-activated that where not activated any engine quit.
At engine start macro groups that where disabled at engine quit are still disabled at engine start.

I still think i think they should be de-activated at relaunch though.

What is the mechanism of activation?


Here are my macro's.

A macro group and a macro that toggles the group as active or inactive.

πΈπ‘šπ‘œπ‘‘π‘–π‘π‘œπ‘› π‘‘π‘¦π‘π‘’π‘Ÿ 2 π‘‘π‘œπ‘”π‘”π‘™π‘’.kmmacros (26.6 KB)
ℰ𝓂o𝓉𝒾𝒸ℴ𝓃 π“‰π“Žπ“…β„―π“‡ 2 Macros.kmlibrary (74.1 KB)

1 Like

Hey @Fokke,

That explains it, and no one would ever guess without being able to directly test the macros in question.

This one does the job exactly as it's supposed to:

BUT – you have the macro group set to be β€˜Always activated’:

That's why it turns itself back on when the Keyboard Maestro Engine is restarted.

What you need to do is ditch the toggle macro and operate directly on the macro group:

That should solve your problem.