Enable Screen Recording for the KM Engine

Hi guys I've an issue with KBM10.... If I look to open the editor I'm told that Screen Recording is disabled.

Screenshot 2021-11-30 at 15.36.19

However if I follow the instructions to fix this, i.e. enable Screen Recording for the KM and KM Engine I'm unable to do this as I can't see an entry in the apps list or the KM Engine.

Any ideas how I fix this?

Isn't there a "+" button under the list of apps, so that you can add a new app? I think that's how it should work for new apps. Press "+" then browse to the KM app in Finder.

Hi Daron - try reading the 4 posts starting here How To Create a Simple Text Expansion Macro - #23 by russmcb

Despite the title it shows how to fix the screen recording issue.

@Sleepy - There is indeed, but once I start browsing the apps folder all I see is the KM app itself not the Engine......

Screenshot 2021-11-30 at 17.24.24

@tiffle - Right that seems pretty complex having to design a script to get the function added. None of my Macros seem like they need that functionality at the moment so I'll hold off trying to get rid of the error for the moment.

I'm so sorry. I think I stopped reading after "enable Screen Recording for the KM". Let me see if I can remember or figure out the rest of your question (It's probably in tiffle's response.)

The full answer appears to be on this page:


The important part:

In Big Sur and later, you can actively add the Keyboard Maestro Engine to the Screen Recording permission in the System Preferences, Security & Privacy, Privacy, Screen Recording settings by unlocking the System Preferences, and then finding Keyboard Maestro.app in the Finder, control or right click on it, select Show Package Contents, drill down in to Contents, and then MacOS to find the Keyboard Maestro Engine.app, and then drag that in to the Screen Recording settings.

1 Like

Not really complicated - just create a macro with one action in and then Try the action or run the macro, as it says in that thread I linked to and in the wiki:

:warning: If Keyboard Maestro Engine does not appear in the permissions, create a Screen Capture action and capture all screens, and “Try” the action or run the macro. This should force the system to notice and prompt you for permission.”

That seems to have got rid of the error message, my thanks.

If the eror message comes back I'll try that :slight_smile:

Hey Daron,

This is because the macOS' permissions settings are buggy.

If you need to find the Keyboard Maestro Engine, here's the simplest way:

Finding the Keyboard Maestro Engine in the Finder

@peternlewis – it really seems like a good idea to add Reveal Keyboard Maestro Engine.app to the Keyboard Maestro Editor's Help menu.

This issue keeps coming up over and over again.


1 Like

Maybe, but the only reason to do this is because of Apple’s buggy permissions, so I really don't want to. It is also more likely to lead to people messing up the application and leading to other support problems.