Error -33933

Whenever I go to use a macro that I create, it comes up with this popup
If someone could respond telling me what this is and how to fix it. Thanks.

Hey There,

Post the macro, so we can see what it's doing.

  • Export it.
  • Drag & Drop the file into the KM Forum Editor.


If you have Keyboard Maestro 7 you can use the share button in the toolbar.


I can’t do it, but when I use any macro, it will just popup that message. Even the built-in macros.

I’ve seen this before and its an indication that the Keyboard Maestro application is corrupted. Download a fresh copy from our web site.

I’ve tried every single version of keyboard maestro, I’ve tried uninstalling them all, and it still doesn’t work. No matter what version, what hotkey, what applications I have opened, it still opens it up.

Sounds like there is some corruption in files used by KM that don't get removed when you just drag the KM app to the trash.

You many need to do a more thorough uninstall using an app uninstaller like AppDelete. It will remove all files related to the app you want to uninstall.

Well, that sucks...

Use the 'Open Logs Folder' item in the KM Help menu.

Look in both logs for clues.

Archive this folder.

~/Library/Application Support/Keyboard Maestro

Follow JM's recommendation and use an uninstaller to remove all other files.

AppDelete will work in demo mode.

I would want to run the Disk Utility and check for problems.

I would probably also want to repair permissions.


Email support directly so we can help you narrow down where the corruption is.

1 Like

I got the same problem, all the Hot key trigger in Keyboard Maestro 8.0.4 suddenly not work, it shows error -33933 , I using Mac OS Sierra 10.12.6

Same to me, help…

did you repaired? Please help😭

I’ve had this problem, too, for help.:sob::sob::sob::sob:

same to me,8.0.5!no one fix it?

Same for me - using High Sierra 10.13.3. Using Macros now by running via arrow in main window.

Once I use the hot key to trigger the macro, I will prompt the -33933 error

I tried to reinstall the latest version of the official network, delete the startup item and completely delete the KM

But I got the wrong hint of -33933. Please tell me what I should do


This error is caused by a corrupted version of Keyboard Maestro from a third party site.

Installing a clean copy from our site should normally resolve it.

Make sure you quit Keyboard Maestro Engine and Keyboard Maestro before installing the fresh copy.

Restarting your Mac is not normally required, but may be required. It is hard to know exactly what damage the corrupt third party version does.

It works - tnx.

1 Like

Whenever I try to activate any of my hotkeys, an error shows up giving me this message "an error occurred while handling this hotkey" I've already tried reinstalling the keyboard maestro app multiple times. This just started happening about a week ago and I have no idea how to fix it.

See This error is caused by a corrupted version of Keyboard Maestro

1 Like