Get Safari url Macro (v10.2) - after migration to Ventura?

Get Safari URL Macro

  • macOS Ventura

Do I need to throw some plist file(s), because I don't even get results from this basic macro?

Some such macros do work, while others don't.

Any assistance will be much appreciated,
OmarKN


get Safari url.kmmacros (3.1 KB)

Hey Omar,

That works perfectly fine for me if I change the hotkey to something else. (That one is reserved on my system for something else.)

Put a beep or a notification in the macro, and make certain it's actually running.

Make sure you have this setting ON:

image

-Chris

If a macro “does nothing”, the first stop should be the Interactive Help in the Help menu, Something expected is not happening.

It will tell you if the macro is active or not, and whether it fires or not. Only after you confirm that it fires should you worry about what the actions are doing or not doing.

1 Like

The Interactive Help is impressive!

It identifies that "The Macro Group is Inactive", which by the way it is not.

Also: I switched off and on the accessibilty settings in Privacy & Security for the 2 KM apps.

When migrating to the Mac Mini & Ventura, also KM was not a fresh install (if I remember correctly).

/okn

This was actually on!
(A setting which migrated from the old Mojave/ Safari setup?!)

=SOLVED_!

With the help of the forum and the excellent Interactive KM Help (→ Help Menu) I managed to repair the macros, of which I have a couple of them, they fetch URL and/ title for example for HTML tagged links, or for Markdown links…

Summary:

  • In one instance, it was enough to change the key.*
  • In another instance, the interactive help reported that the macrogroup is inactive - although it was active, but then → I changed availability (from availability for Safari and Google Chrome) to all applications (availability in all applications, available in all windows, always activated) and it worked.

*(The interactive help said that the macro had no triggers, but it had H - ? , replaced the " ? " and it worked. On Mojave H - ? was no problem, and still the same physical keyboard.)

So this was success!

/okn

Thank you.

The macro group is inactive. It is enabled, but it is inactive because you are not in Safari (or if you upgraded to Ventura, because Safari moved from its old location and you need to reselect it).

The difference is likely related to the keycode changing for some reason.

The macro group was inactive. The Interactive Help knows what its talking about.

2 Likes

it is inactive because you are not in Safari (or if you upgraded to Ventura, because Safari moved from its old location and you need to reselect it).

→ because Safari moved from its old location and you need to reselect it.

Yes, this was it! Learned something new again. :slight_smile:

Now all those macros are working flawlessly!

/okn

2 Likes