Global Macro Group cannot be renamed

After creating several new Groups, I decided to organize the Groups list to easily distinguish between “all applications” groups and the groups limited to specific applications.

So I went through the list and added a bullet (•) prefix to the names of the groups that apply to all applications, which moved these groups to the top of the list, right after Enabled Macros.

Unfortunately, the Global Macro Group can’t be renamed, leaving it in the middle of the specific applications group between Firefox and InDesign.

Is there a reason the Global Macro Group has a hardwired name?

The rest of the default groups (Application Control, Clipboards, Switcher Group, and even All Macros and Enabled Macros ) can be renamed. I left the latter two unchanged because they’re fundamentally different and already have their own segment of the list.

You’re not the first to mention this, and unfortunately, you’re stuck with it.

1 Like

Thanks, @DanThomas, for your speedy response. I didn’t find any of those mentions in my search of the Help and this forum.

No problem - I didn’t mean to sound like I was criticising your search abilities. I only meant that you’re not alone in wishing you could rename this group. :slight_smile:

1 Like

I, too, have just discovered this limitation.

DanThomas, why do you say that we're "stuck with it"? Has the developer stated that he's unwilling to change this? Because certainly this behavior could be changed.

It's also odd that the enable/disable button doesn't work for the Global Macro Group—yet, the group can be enabled/disabled via a command in the View menu. Is there a reason for the inconsistent behavior?

Honestly, I don't remember. This is a question for @peternlewis.

1 Like

Thanks. :slight_smile:

The Global Macro Group is always named the Global Macro Group and cannot be disabled. If you want to be able to disable or change the activation of the group, make a new macro group called Mostly Global Macro Group or whatever you want and move your macros there.

It is a bug that the View ➤ Disable Macro Group is enabled for the Global Macro Group and appears to disable the Global Macro Group. Indeed, it only appears to disable it, it beeps to complain when you do that and the group remains enabled.