Google Drive (not Backup & Sync) does not trigger syncs when using Macro Sync Files

Google Drive -- formally only available to business accounts -- which syncs using a virtual drive where material can be stored in the cloud or locally -- does not trigger syncs.

I've tried with three macOS machines, two on Mojave, one on Catalina. I've also tried making the file persistent (always cached on each machine), and that does not change the behavior. You can definitely see that the file modification date has changed, so I'm not sure if this is some filesystem events issue not being triggered?

I've also tried the same scenario with DropBox, and the sync feature works perfectly with DropBox.

All machines have read/write access to the file for owner via Google Drive when viewed in macOS, however comparing permissions with DropBox -- it seems DropBox also grants permission to the 'staff' group as well.

I tried clearing out the macro sync file, and creating a new one, and then having the other machines attach to that. Does not fix the issue.

Any suggestions?

Basically, unless this is somehow unique to my machines, it means that the newer Google Drive software (for business or personal user) is currently not functional with the macro sync feature.

Thanks in advance for any insights.

I’ve just discovered the same issue. I was thinking it was related to upgrading to Catalina, but it looks like it’s Google Drive. In my case, I was already using Google Drive over BackUp & Sync, because of work accounts. I’m guessing it’s a change that occurred when Google ‘reunited’ the product. Anyone else having this issue that has a fix or workaround?