Having Trouble Installing Plug in Actions

Every tutorial I read about the installation process tells me to drop .zip files on the Keyboard Maestro icon on the dock. That is what I am doing but can't find the actions anywhere. Not sure if I am missing a step somewhere. Any advice?

You need to restart the km editor after the dropping.

Tried dragging .zip folder onto KM icon. Restarted KM editor. Still nothing. I also tried manually moving zip folder to KM plug in actions folder.

If you’ve installed them correctly (and it sounds like you have) then in the KM editor you have at least 2 ways to get to your installed plugin actions as shown in this screen grab from the KM wiki:

I’m not at my Mac right now so I hope you can figure out now what to do.

PS - don’t go dragging zip files into the KM actions folder!

Thanks. I have also tried looking under "Third Party Plug Ins.” but nothing is listed there. Also tried inserting by name but still not seeing any I've installed.

No - you need to restart the KM Engine.

I restarted the engine completely and still nothing under third party plug ins.

What plug in are you trying to install?

Last one I tried was Execute a Script in Terminal.

The answer to your problem is given in the thread where you got the plug in from.

See here:

And make sure you’re using the most recent version of the plug in - 2.1 I think.

I have a folder that says Execute a Script in Terminal.zip (which is what im dropping on the KM icon) Inside the folder there is an AppleScript file, KMAction.plist and a PNG file. Not seeing dmg file.

Can you upload the plug in for others to test?

Then you're doing something wrong.

Because @Tom chose an unconventional way to distribute his plug in you have to install it slightly differently to the way described in the KM wiki. This is described fully in the thread I pointed to earlier but I'll spell it out for you here:

  1. Download the plug in file Execute a Script in Terminal-210.dmg.zip to your Mac
  2. Unzip the file to get the dmg file Execute a Script in Terminal-210.dmg
  3. Open the dmg file and agree to the license
  4. When you see this KM 0 2021-04-11_14-05-18
    follow the instructions by drag/dropping the Execute a Script in Terminal.zip file onto the KM Editor icon in the dock (after first removing any existing version of the plug in from the KM Actions folder)
  5. In the KM Editor, use File>Quit Engine to stop the KM Engine.
  6. In the KM Editor, use File>Launch Engine to restart the KM Engine.
  7. The plug in should now be available to add to any of your macros as described in a previous post above.

If you don't follow these steps exactly, then that's what you're doing wrong. I've just followed them and this is what I see in my action list:
KM 1 2021-04-11_14-14-45

Good luck - let us know how you get on.

BTW - what version KM are you on?

That a bit cheeky @martin - you can download it yourself, you know :innocent:

Sorry. I did not realize what @Barlow was referring to.
It seems he was referring to the last plugin here:
Keyboard Maestro 9.2: Third Party Actions

I downloaded it, dragged it to the KM icon on the dock. It shows up in the action list immediately. I did not even restart either the Editor or the Engine. @peternlewis, Is a restart of KM (Editor/Engine) really needed?

Also, I was trying a simple cmd as echo. But the result of the plugin is a list of the folders in my home directory. Edit: my bad. Apparently, I did not observe carefully. This is exactly what the plugin does. (But I don't know what the text and the Check Box are designed for. Edit: Just took a look at the sh file. The text and Checkbox do nothing in the sh script file.)

A simple example Shell Script action that lists a directory and shows some of the other types or parameters you can use.

I don't know how that translates into Execute a Script in Terminal.zip

Sorry, I don't understand what you are saying.
To install the plugin, just download the zip file, dragged on the KM icon on the dock.
Without a restart of either the Editor or the Engine, the action shows up in the action list immediately. See "Example Shell Script" in the screenshot below:

What I’m saying is the plug in you are referring to is called Execute a Shell Script or Example Shell Script while this thread is about the plugin called Execute a Script in Terminal

I see. Sorry. I just assume he was not referring to the plugin you mentioned. Since the OP appears to refer to any plugin.

It's not a dmg file, it is a regular plugin file that has the required files. (Probably my guess was wrong as well. The plugin I referred to is not an AppleScript but a sh file.) So I have to come back to my original question:

It's not letting me upload the folder but this is what I get when I download a plug in from this site.

Screen Shot 2021-04-11 at 11.38.21 AM

Inside the folder I only see:

This is the same type of folder I get anytime I download a plug in (or try to) from this forum.

I'm sorry if I'm missing something obvious here. I appreciate all the help.