High energy impact on macOS Sierra Public Beta 3

I’m running Keyboard Maestro 7.2.1 on macOS Sierra 7.2.1. The energy impact is consistently between 8 and 10, with the average energy impact around 19. I’ve confirmed that no macros are running and the editor window is closed. I’ve not seen this behavior under El Capitan, so I’m assuming it’s a result of some issue running on the beta. I understand beta OSes can’t be supported and it’s not a big deal in the grand scheme of things, but I was wondering if anyone else sees this and has any suggestions.


Seeing an average energy impact of 0.22 here. Seems to compare favourably with LaunchBar etc

KM Version: 7.2.1
MacOS: 0.12 Beta (16A269f)

Thanks for the info. I just disabled all of my macros and the energy impact dropped to .2. Odd that no macros were running before I disabled. I’m going to re-enable one at a time to find the culprit.

There’s a couple of threads on how to use existing KM features to see the most recently run macros, but I can’t find them.

There’s this, that may help: MACRO: Get Recently Run Macros with Last Executed Time

Thanks, Dan. Funny thing is that I haven’t run any macros in a few days and have restarted my Mac a couple of times. All of my enabled macros require a hot key or use a text trigger, so I’m not sure what might be causing this. I’m about halfway through re-enabling them all, so I hope to find the offending macro soon.

Well, using the aforementioned macro, you could just enable them all, then run the macro to see what’s run recently. No need to do one at a time.

Doh. That makes sense. I’ll give it a try. Thanks!

The macro isn’t showing any recently run macros. Nice thought, though.

None at all, or just since you restarted them?

The macro shows macros I ran a few days ago - the last time I know I ran one.

I found the culprit. I have a macro with a trigger: “This device key:” and it’s look for Magic Keyboard F11 to be pressed. When enabled, the energy usage jumps up. Oddly, I tried to edit the macro and found I can’t set the device key now. I’m not sure how I set it to begin with. My goal was to remap the Magic Keyboard’s volume up and volume down keys. I have a USB digital to analog converter that doesn’t support the normal keyboard volume controls. I didn’t want to remap the actual F11 and F12 function keys, so somehow I managed to get it to work with the device key approach. I’ll switch to using F11 and F12 for now while I see if there’s another way to do it.

Thanks again for the suggestions.


Thanks for the info. I will check out 10.12 (installed on another partition) shortly and see if I can duplicate it (but I am not running 10.12 normally, so it’s difficult to test well). Can you check just creating another macro, using the USB Device Key trigger, and setting it to anything (a normal key, or the mouse button) and see if that causes the performance issue for you.

Also, it is possible it is a 10.12 beta issue - betas tend not to be optimized. It would be a bit weird, but not impossible.

I recreated the macros and everything seems to be behaving now. Maybe there was some kind of corruption? Thanks for considering support for the beta OS. Please let me know if there is any other information I can provide.