How to Hide (Exclude) Specific Applications in the KM Application Switcher in Specific Desktops

For example:

I want to hide Mail and Messages when I'm in Desktop 2 in Application Switcher, or hide every app that isn't active in my current desktop.


And how useful would it be to optimize our focus.

There is no way to do that. Currently Keyboard Maestro does not even know which space an application is in, or which space you are in, and while I have heard some rumours it may be possible, I don’t currently know how it can be found out legitimately.

Thanks Peter, not what I was hoping but what I needed to know. Terminology fun with Apple changing from Spaces to Desktop.

Technically, it is windows that spaces contain not applications. It’s a complicated story, but although typically when an application has been assigned to a space switching to it will switch to that space. However, if you have moved one of its windows to another space, and you are currently on that space’s desktop, and open a new window, it will open on that new desktop, not where you think the application is. Or something like that. I posted a better explanation somewhere on the forum but haven’t found it yet.

Hi Peter,

I’m assuming Apple has not yet provided the proper public API to manage spaces yet? I’m not sure how to check on the Apple developer site myself.

It would be great if we could customize the App switcher to only show apps with windows open on the current space. I can think of other good macros (closing all windows in the current space, etc) which need this improved API also.

As a workaround, I’ve just manually excluded everything except apps I use in development (i.e. VSCode, iTerm, Chrome) and can use the “e” key to see all apps while the switcher is open but hoping the situation has improved?


I know this is an old topic, but I was thinking the same thing and found this thread.

In KM 10 we are now able to hide/exclude certain running apps from Application Palette.

Are we now able to do the same for the application switcher?

(For me, I do not care about the specific desktop/space/stage. A global option would be fine.)


Have you tried adding the apps you want to exclude to the first, application switcher, list in the "Excluded" pane of KM's Preferences?

1 Like

Thanks for the reply. I did not recall the "Excluded" pane in the Preferences. Wish there was an exclusion list directly under the Application Switcher action.

However, even after I set the exclusion list, it is still not working for the Switcher (the Application Palette works though). --see the snapshot

Works instantly for me and as advertised (KM 10.2, macOS 10.14 on this machine).

Try activating the Application Switcher with ⌘⇥, keep the ⌘ key down, and hit the E key. Does that fix it? (I'm wondering if you've previously hit the "Show excluded applications" toggle...)

Thanks again for your quick reply.

It turned out I did check "Show excluded applications" -- I might have set it years ago.

Again, these settings could be improved and made more visible to users.

Thanks for your help!