How to stop macros timing out after a certain amount of time?

This is my first time using long/looping macros but it keeps stopping. It always stops in random places or random macros (since certain macros start other macros in a loop), even simple places that should be fine. At first I thought something was buggy but everything seems on point and it will loop multiple times perfectly. But it just kept stopping, so I timed it.

I timed it four different times and every single time it stopped at pretty much exactly 150 seconds no matter where it was in the sequence. Is this a default or something? I can’t find any auto macro stop thing after 150 seconds but my macros seem to be doing it. This is almost defeating the point of a looping macro if it stops after a certain (short) time.

Edit - I keep trying and every time it’s 150 seconds. There has to be a way to disable this.

You can set the timeout on any macro action from its gear menu:


However, this timeout is set to 99 hours by default, so if it's stopping after 150 seconds even though its task isn't complete, it sounds like there may be something else going on causing your macro to act that way. Can you upload/post your whole macro here so we can take a look?

1 Like

Thank you gglick. After trying that and many other things I set upon the correct solution - ‘Asynchronously’ needed to be checked throughout. I had set up the macros to execute a new macro at the end of each in a loop that was variable depending on the circumstance. However, since Asynchronously wasn’t checked, each macro was still ‘on’ and I was creating layer after layer of macros in a chain with all remaining ‘on’.

It aborted after 50 macros were on at once (I didn’t have 50 different ones, but it counts the same ones starting again as another and another and so on). I found this out by looking at the logs and then deducing that Asynchronously would stop that. Even though my loop was variable it seems the different loop possibilities all timed the same, which is why I reached the limit and then the macro stopped at the same time every time.

1 Like