HyperKey Not Triggering Macro

Has anyone gotten Hyperkey(https://hyperkey.app) to be recognised as a hot key in KM?

If so, please share how you did it because I can't seem to make it work.

I don't use the Hyperkey app, but you may need to press the Command-Shift-Option-Control modifier keys (instead of Caps Lock) when setting up a Hot Key in KM.

Recommend Karabiner-Elements:

1 Like

I started using HyperKey only recently after seeing it mentioned on either this forum or the MPU forum.

You just need to make sure the keyboard shortcut combinations match and you should be good to go. I've included an example below.

Screen Shot 2022-10-26 at 19.35.27

There are people who indeed need HyperKey (⌘⌥⌃⇧+letter) for certain reasons. But for many it is enough to switch the Caps Lock key with Control in macos. This has the advantage that no problems occur because right control is a real modifier.

Too bad that KM can not distinguish between left and right modifiers. This would probably be the best replacement for hyperkey.

By the way, I doubt that the shown combination ⌘⌥⌃ is a good choice as "hyperkey" because it is already used by many apps. I think ⌃ alone occurs more rarely. Just saying :slightly_smiling_face:

From the HyperKey FAQ:

Why can't I record my shortcut with Hyperkey in Keyboard Maestro?

  • Keyboard Maestro's shortcut recorder works a little differently than most, BUT if you just record your shortcut physically pressing all the modifiers, then the hyper key configured in Hyperkey (or Superkey) will properly trigger what you have configured in Keyboard Maestro.

Coincidentally I switched to HyperKey a couple of days ago after having used Karabiner Elements for many years. Ever since upgrading to Monterey about a month ago, I was finding that I had to deactivate and then reactivate Karabiner every few days because of some permissions issue, and so I decided to try HyperKey. All my KM macros using the hyperkey have been working without any problems.

For some reason I can not get this to work. I have disabled CapsLock in system settings and set it up as hyperkey in the Superkey (paid version of hyperkey):

Then I created this macro in KM:

When I press all three keys individually and V key - the macro is triggered. When I press CapsLock + V - absolutely nothing happens!

I've seen topics along these lines before and while I can't offer specific help I can suggest you search the KM forum. Try this for starters: Search results for 'Hyperkey not' - Keyboard Maestro Discourse

Launch Hyperkey and see if you have unchecked the option to include Shift in the hyperkey.