In MacOS 11.2.1, Replace Function Not Fully Consistent, Some Start Characters Will Not Prompt Replacement

I know this is not truly a KM related problem, but the technical aspect bothers me!

In my use I rely heavily on using abbrevations (for names) like this: dodu is replaced by Donald Duck... it has just worked fine. I have more than 100 items in my list.
Then one day last year any abb starting with a 'q' or a 'z' did not work. There are only a few of those and I worked around by starting the abb with a 'c'. ( put a slight load on my memory) :grinning:

Now, some weeks ago anything starting with the digit '1' gave no responses either. Thus 1/2 will not be shown as ½ ... bummer... I have no inkling where to look for the reason / repair of this bothersome random mishap.

Am I the only one experiencing this???

Would be happy for some advice. SO my faith in Apple macOS can be restored. Is there maybe a maximum for the number of items in this feature? Where one might reset its behavior???

As it happened I saw in a different topic here, the mention of Typinator. I have gotten this and it works perfect for this purpose, so I may move all my "replace-with" to Typinator.

still that solves not the macos bug

I attach a screenshot of the top of my long list. The 5 abb shown starting with 1 does NOT work now!

Kind regards
Palle GT

Hey Palle,

This is a very unlikely circumstance.

Have you tried killing the Keyboard Maestro engine to make sure you don't have a conflict?

Have you installed any other software that could be the crux of the problem?

Personally I use Typinator for text-replacement, because the System › Keyboard › Text preferences are so functionally limited.

I also have almost 50,000 replacements...


Yes indeed it is an unlikely thing, yet it is there. Stopping KM and KM Engine makes no diff.
the bug lies somewhere in macOS.

I have purchased license for Typinator now and do like it, followed the instructions and imported the full set from the .plist, about 1.200. no pain.

I agree that the possibilities in Typinator is better and most of all visible :slight_smile:

On job's remaining: to purge the macos replacement rules

still it would be interesting to hear if others have similar experiences as I had.



I did some quick searching on Google and didn't find anything obvious.

What language are you running macOS in?

And what keyboard input?


I use Danish, but resetting it to English and rebooting change nothing. my keyboard is USB-wired Satechi. I am very satified with that. I have two separate units on my desk, so for exact connections and non-hesitating response I chose this over their Bluetooth versions. You may use one keyboard for 3 different units by pushing some buttons and prayin for connection, but not for my tempo.


My systems now run Typinator, only. It was simple to export the list from macos, and then purge it, to avoid possible conflicts. (1.240 replacements in fact)
After some minor trimmings Typinator is running great and actually saves me 50% on related mouseclicks and the 'dd' (todays date) is still super


1 Like

Hey Palle,

I don't use automatic smart quotes on my system, because I wrote so much code.
So I have 4 text-expansions to add them when needed.

sq   ==  ‘|’
dq   ==  “|”
sqq  ==  ‘<clipboard>’|
dqq  ==  “<clipboard>”|

** | represents the cursor. (2.3 KB)

Typinator saves me thousands of keystrokes a week and has good synergy with Keyboard Maestro.