Issue (bug?) with Hot Key trigger held down


I stumbled across something that appears to be a bug, or else me doing something stupid.

I’m defining a hotkey trigger, say “alt+5”, and setting it to do 2 things: print the character “8”, and disable a specific macro group.

If the group is already disabled, then there’s no problem - alt+5 will print the character “8”, as required.

The problem is, if the group is enable, it will indeed be disabled, “8” will be printed, but a few seconds after that, the “original” behavior of alt-8 will start happening. In this case, it means the “infinity” character will be repeated endlessly.

Is this indeed a bug? Or am I doing something wrong?

(The original reason this came up is that I’m using enable/disable group as a way to implement an “if” statement, to make KM behave differently depending on whether a key combination is pressed or not. This issue causes this to not work well. I can elaborate if necessary, but I tried to give a cleaner reproduction of the issue).

I couldn’t duplicate any of this behaviour, so something else is likely going on.

Check the Engine.log file and see if any other macros are firing.

Other than that, there might be some bad interaction with some low level software (eg the Logitech Command Center or whatever it is is known to have issues with messing up modifier keys).

Where can I find the Engine.log file? I can’t see any documentation explaining where it is.

Regarding duplication, this happens on two different laptops that I have, so it does seem to duplicate for me at least. It could be some low-level interaction, but it seems very KM specific, for the following reasons:

  1. The “bug” is completely dependent on whether KM needs to run the “disable group” action. If the group is already disable, the “bug” doesn’t happen. If I enable it, then the action is run and the “bug” occurs.

  2. I tried switching the action from “disable group” to “deactivate group”. This caused the “bug” to disappear. This isn’t a good solution for me for other reasons, but it points to the idea that the issue is specifically with the enable/disable group action, and not with some other interaction.

Is there anything else I can do to get to the bottom of this? If it helps, I can export the relevant groups and macros I’m using to help you reproduce…

Help->Open Logs Folder

Disabling a macro will interact with the Keyboard Maestro editor if running, which will probably cause the macros to be reloaded by the engine, so it is quite an big hammer as far as tools for controlling macro activation goes.