It doesn't open finder selection anymore on the latest Mac OS?

it doesn't open finder selection anymore ∑( O_O;) shock !!
after Mac OS updated =="


QuickTime Player is an odd duck... sometimes I get random errors when opening mp4 files that it’s ‘not a valid format’ or some other nonsense like that.

It may sound silly, but have you tried a reboot? Can you right click on the selection and use the Open With option without problems?

drag and drop to open is OK.
it just fails the keyboardmaestro shortcut.

I wonder if that action is pointing at an older (now missing) copy of QuickTime Player ?

Perhaps worth deleting the action and recreating it.

1 Like

It's not a QuickTime Player problem. The same thing happens when using a macro to open .jpeg files in Affinity Photo. Also, .docx files in Word and many others. It worked before a recent macOS Sonoma update.

128_error

already tried to create a new macro, still, it fails QuickTime Player only, not other applications.

1 Like

exactly !

I use the following method now. Note that my macro was shortened for brevity.

i can't find the Affinity Photo.
could you save the Macro for me m(_ _)m

the error code is -128
it doesn't open through finder selection but a directly file link =="