KBM Kindle Highlighting Macro Works.. then doesn't

Hi, I have macros that have successfully highlighted selected text in Kindle (The MacOS version with Big Sur 11.4). One macro for each of the four colours.
Each has its own hotkey trigger. The one action is to move and click at (X,Y) from the centre of a found image, where the image is a file copy of a screenshot of the four coloured buttons available for highlighting in Kindle. I worked out exactly how many pixels by using the screenshot programme on OSX on the image that appears automatically when you select text in Kindle. To my surprise and delight, this worked fine for a whole session. When I rebooted the Mac it no longer worked. It may be the latest update to Big Sur, but I somehow doubt it, because I have had this 'macro not persisting' issue with this function on earlier updates. I don't believe it is the update, but the persisting over login sessions that is the issue. I have tested that a simple alert macro does work ok on KBM and Kindle. Any help appreciated.