KBM takes up 572% CPU

You set a timeout on the actions using the facility if desired.

The find image facility itself does takes only a limited time, so it does not make sense for it to have a timeout. The issue of CPU usage occurs when the facility is used continuously, thus requiring a timeout at some higher level, at the action level.

OK… I have appeared to have tamed the issue. OK on the finite time for the “find image” facility. I will keep an eye out for further problems but appreciate the help.

Hi @radiator - how did you Resolve the 'find image' facility on your particular workflow - I used this on a couple of my workflow and do notice that CPU utilisation goes high after a while...

  • it does a standard check for this app or that

Maybe it is me, however I do not want to continually use iStats or Activity monitor as this uses unnecessary CPU in the background (though minimal) - (ie. I am using a laptop - not desktop)

Here it my workflow which uses to search images twice in #1 and #2.
I am not too sure how to configure so it searches for a particular input text box...

Wondering if it is even possible to say watch for CPU utilisation which if goes over 100% for KM and runs longer for > 1minute then restart KM.

I use dropbox, one drive for work and I have set schedulers so it turns it on in the morning, before I leave office and at night so it doesn’t drain the laptop battery (hence cautious re battery drains).

Read my initial answer, it has not changed, and is marked as the solution to the problem.

You need to put a timeout on your Pause Until actions.

I don’t understand your macro at all though, it triggers when Cisco activates, and then performs actions only if Cisco is not running, which would never be the case when Cisco activates, so I presume something else is triggering this macro as well.

Nobody wants high CPU usage - you should never have high CPU usage with Keyboard Maestro unless you are actively asking it to do something hard. If this is “always” then the solution to this is to stop it from continously doing something hard.

You probably could, but this is a terrible idea. Why restart Keyboard Maestro just to cancel a macro which shouldn’t be running in the first place. if the macro is running when you don’t want it to be running, then resolve that using a timeout or otherwise.

Hi @JOkere,

Just some anecdotal remarks relative to KM and CPU over the past year.

One thing I have learned with KM is the Control/Option/Command/Escape feature which simply kills a running script. (It does not kill the KM engine. If I see KM in a high CPU state, this fixes it. I use this once or twice a month. And I guess that if I have to, I can set up a kill timer in the scripts of interest.

I believe ALL my runaway CPU issues with KM are related to image recognition issues, probably stuck in a loop. I use image recognition fairly often, probably more often than I should. In general, I do find VERY useful, and I execute many KM scripts employing image recognition many times every day.

I also am always running Activity Monitor. (see attached image).

I have 16GB of RAM and drive 3 monitors. Even with 20 apps open, the computer just purrs along @ low CPU usage. If I see the icon flaring up with a lot of proc usage, I can quickly go and figure out why. KM sometimes is the culprit, but more times than not, there is another culprit.


It happened again (CPU 400%), and again was a find image problem.
Now, 2 years later, I can't find the menu item you are referring to. Where is it in the menu ?
thank you Peter

In the Keyboard Maestro status menu (the icon menu in the top right corner of the screen).

The Cancel submenu is near the bottom of the menu.

Everyone should have a "cancel all" macro. Mine looks like this:



I created the macro. thank you.