Keystroke macro not repeating

Hi all,

I have a new M1 MacBook Pro running Big Sur and have successfully imported my macros from the old machine. But my forward delete macro is not repeating, which is driving me nuts!

I've already turned off the "press and hold" setting via the Terminal, with defaults write -g ApplePressAndHoldEnabled -bool false, and restarted. But the macro still only does one forward delete at a time.

Can some kind person please help me out?

Thanks! :smiley:

I don't understand much about it, but have you tried "is down" instead of "is pressed"?

1 Like

Try this method. It's how I adjust screen brightness and system volume and it works great.


Forward delete.kmmacros (2.8 KB)

Macro screenshot (click to expand/collapse)

Awesome! Thanks so much, Chris.

Now, does anyone know why this sort of control flow is necessary on the new Macs? (for my problem, Chris' problems and no doubt many others) The macro on my old machine is the simple one-step shown above, and works perfectly.

Because pressed is a single action. KM recognizes the button being pressed once, and performs the action. It won’t recognize it being pressed again until the hotkey is release and pressed again.

Looking at your initial post and @Frankb response, he is right in that you could simply change the trigger to "down" instead of pressed and then have this single action:

P.S. I can't remember why I set up my brightness/volume macros the way I did, but I did have a reason for it at the time haha.

Forward delete.kmmacros (3.3 KB)

Macro screenshot (click to expand/collapse)

Interesting. The simple solution (down) only works with Delete, Enter and so on. but not with letters a, b, c …
With letters Chris’ solution works perfectly :slight_smile:

1 Like

Oh, I understand now -- I thought Frankb was talking about the options you get when you press on the gear icon on the side of the action itself, and I'd already tried those.

Shoulda read more carefully -- oops!

1 Like

I suspect that's because of the press and hold setting which I mentioned in my original post. It's to help people enter accented characters, so if you don't need that you can turn it off. Even if you do need it, there's a moderately easy way to achieve it via option and a small subset of keys. (I can list them if you need them)

1 Like