I suggest a permutation (sometime ;-)), for purpose of clearer indication, of
︎ / → (x) and ︎ / ↓ (y) for window size / position actions.
would be clearer (more intuitive) with
is OK as it is.
This cosmetic change (clarification) is mainly interesting for Move
and Resize action
which is OK too in consistency display / action.
But, when the happy KM 7 user change its mind from "Resize" (330, 500) action to more general "Move and Resize" action, the above action would better be
auto magically set...
Possibly, although that might give the impression the window would stay centred where it was and expand the size in all directions.
But, when the happy KM 7 user change its mind from “Resize” (330, 500) action to more general “Move and Resize” action, the above action would better be
You’re probably right, but the complexities of implementing this are likely to exceed the benefits of this until I get the rest of the todo list down below ten thousand entries…
To summarize my point is simply:
Associate biunivocally (visually)
︎ (x) and ︎ (y) to Resizing and → (x) and ↓ (y) to Moving to avoid ambiguities for these four parameters…
But I don’t want to bother you
I just extended
a macro I copied that displayed the size of a window and extended it to show the position too. I was looking for a set of icons that would represent left, top, width, height. The original macro used → and ↓ for width and height, but to me these read as distance from left, and distance from top. So that's how I used them, and I used ━ for width and ❙ for height.