KM 9 Conflict Palette behaves differently

Since installing KM 9, some of the macros will not execute using the lower case conflict letter unless holding down the shift key while pressing the highlighted letter for the conflict palette, or selecting it with the mouse.

For example:
Trigger a Macro group, which displays an n) ordered list, with conflicts in the names.

Some of the names:
15) UEXT conflict E
20) UCTT conflict C

I'd expect to press , "u" (does work), "e" (does not work) as I did with KM 8. However "E" does work.

In another example, I'm using
All Caps conflict C
All Maps conflict M
, "c" (works), "m" works.

I've tried: 1) swapping triggers between functional and non functional groups, 2) changing conflict key characters with the issue, duplicating the macros, etc. Nothing helps macros that are "broken", and nothing I do can replicate the bug in the macro group that works.

I've tried creating a new macro group, and I see the same behavior. If I move the macros to the group that does work, I see a second bug where the conflict character highlighted is the same first character that causes the conflict in the first place.
UEXT (Conflict U), (Second Conflict E)
UCTT (Conflict U), (Second Conflict C)

Is there a better way to troubleshoot this.

I can't reproduce the behavior you are reporting.
Running Keyboard Maestro 9.0.1d1 on macOS 10.14.5 (Mojave)

Perhaps it is because my Macro Group and Macro setup is different from yours.
Please post a screen shot of:

  1. Macro Group Definition
  2. Macros in Macro Column in that MG

Here's Mine:



When I trigger the MG Palette, I see this:

Obviously two macros have the same trigger: "U"
so I type "u" and see this conflict palette:


Then I type a lowercase "c", which works and triggers the first macro:
showing this notification:


Thank you for the testing you performed. Both issues still persist intermittently through another hour of testing.

As I delete some of the extra macros, the "U" conflict group goes from highlighting all four initial "U" characters in the conflict palette, to what I show in the last graphic. I tried deleting the macros one by one, but it results in repeated crashing of the KM engine.

Macro Group:

Macro list (trimmed down to the macros causing the issue):

Press "U" to activate the following:


Lower case letters do not trigger macros in conflict palette, but uppercase characters do:


The conflict palette eventually accepts lower case letters, when all other macros in the macro group are deleted. Also note: when creating this test group, the initial "U" in the conflict palette are blue. I neglected to get a screen shot of this.

Could the "U" near the right margin in the palette be a clue to in appropriate configuration of the conflict palette?

Simple suggestion: convert macro names to lower case?

Not sure what you mean by that. Those characters on the right are simply the hot key you assigned to that macro.

Great idea. Unfortunately:

  1. These entries abbreviations, resulting in LONG names that conflict for the first several characters

  2. Some, but not all of the lower case conflicts require upper case letters to proceed!?!

I'm completely stumped. Every time I reorder, remove, troubleshoot, etc., I see different, inconsistent behavior.

I've gone to the "all macros" group to look for conflicting triggers, and have disabled all of them. Still get inconsistent behavior.

Could my macro library be corrupt? Any way to repair or rebuild from scratch?

Not likely. But to troubleshoot, I'd create a NEW Macro Group, and a few NEW Macros to model the behavior you are seeing. In fact, if you can do this without revealing any sensitive info, then you can upload the new MG and Macros for us to test.

BTW, what versions of KM and macOS are you running?

KM 9.0 and MacOS 10.14.6
Also using Better Touch Tool and Karabiner Elements.

  1. Created a new group, and new blank macros. Works as expected.
  2. Disabled blank macros, moved in malfunctioning macros only. Works as expected.
  3. Moved in all other macros. Breaks both blank and malfunctioning macros again.
  4. Move all other macros out of the group, blank and malfunctioning macros work again.

I'll do more troubleshooting. I tried this before, and can't seem to find the macro(s) that are causing the issue.

I usually use the "Divide and Conquer" method:

Starting with the MG where everything is working OK,
Copy all suspect macros into the new MG
Confirm you still see the issue.

  1. Remove 50% of remaining until you don't see the issue
  2. The problem macro is in the last group you just removed -- the suspect group
  3. Remove all macros in the MG
  4. Copy all of the suspect group into the MG.
  5. Repeat steps 1-4 until you have identified the problem macro.

I hope that was clear. Seems much more complicated when writing/reading it that it is in my mind.

Thanks for the advice. The issue is...


() = first letter not in conflict

The conflict palette works, until I move actions with trigger characters that match the same letter of the conflict palette. Those and only those fail, unless I use a the shift to execute them.

Looks like KM9 has expanded the scope of triggers beyond the conflict palette when it appears.

Anyone know if this working as designed in KM 9? How do others knowingly avoid conflicts?

Sorry, I still don't get it -- still can't reproduce your issue.

My conflict palette:


Note that the conflict letter for "UDI" is NOT "U", bu "D".
When I type a lower case "d", it triggers.

It is possible this is related to the changes in activation of "for one" groups/palettes and conflict palettes, which should be improved in 9.0.1.

See if that fixes it (when it is released, hopefully next week), and otherwise I can take another look.

Thanks Peter, will take a look.

I just noticed that the group palette, which is set to "for one action", remains after the initial keypress, which gives further evidence KM is having difficulty resolving conflicting triggers.

By the way, love the new forum interface, and that it saves replies!

9.0.1 appears to have resolved the issue. Thank you!

1 Like