KM Finding an Image That's Not There 100%

I have an action to find this image:

image

And even when my image is like this below, KM still assumes the image is there, which is not:

Why is this happening? I saw that decreasing the blur all the way to the left helps, but is this the only workaround?

This is actually not the first time I see this happening.

Not sure why, but why not test only on the lower part of the image if that is the differentiator?

2 Likes

This is good advice. Also, do you have the image search set to "Best" or "Unique"?

That is a good workaround, thanks.
But still, shouldn't this work as expected, if the image is not 100% accurate?
I mean, if the image is not what I picked, workaround or not, it shouldn't pick as "the image is there", when it's not, right?

Do you have the image search set to "Best" or "Unique"?

Neither, because I'm using the IF THEN ELSE and for that type of action, there's no Best or Unique (or any other option)
image

What if you change all screens to the the front window?

Same thing. I tried all of them and none gives me the other options.
Can you set this when using the IF THEN ELSE on your version of KM?

How are you trying the image search? By triggering with a hotkey or by clicking Try in the KM Editor? If the KM Editor is the front window, the image may be seen in the action's image well.

If this isn't the issue, post your macro and I'll have a look.

I'm using the Trigger Macro by Name, because I'm creating different versions of the Humanize Function.

But when you add the IF THEN ELSE action, are you able to see those other options? Best, Topmost, etc?

No. Post your macro.

I noticed that the PAUSE action doesn't have them either

Humanize - All Macro

Humanize - All.kmmacros (217 KB)

What are you trying to do with this macro?

What does this attempt to click?

Why is this referencing a variable that doesn't exist?

I created 4 versions of the Humanize. One for ALL, one for just the position, one for velocity, one for length.

This was actually just a "Move", not click. But fixed it now.
It's just to avoid the mouse being on top of anything that could be necessary when it comes to the Found Image. Sometimes it's in the way so I just moved it.

It's actually the second action at the top inside the group. it's related to the previous question. It returns to the original position.
I don't know about you, but I don't really like when the cursor starts at a certain position and after the macro runs, it's somewhere else. My brain doesn't really process that the best way...
It's just an OCD thing. Don't worry...

That's not necessary.

Ok, my mistake then. I deleted the actions at the top and replaced them with the new method of selecting the Humanize menu (from the other thread). My bad.

How are you getting the Humanize window to appear without this?

It would be helpful if you described in detail what you're trying to do in that window, specifically.

It looks to me as though all this macro does is get you to the Transform window and then select Humanize. We've already achieved that in the other thread.

If you're simply wondering why the image condition isn't working, I've tested here and it works fine. I'd just take the win from the other thread and move on.

You mean when KM scans the screen, it ignores the cursor? So if an image has the cursor over it, KM is not taking into account the cursor at all?
I was pretty sure I experienced situations where this affected, but maybe it was something else then.

If you open the Humanize for the first time, you will see those 3. Now try and set the position, for example, to Thru and close that window. Then open Humanize again. Logic saves the window state. To fix this, I have those extra actions.

I know I sometimes add extra actions that can be achieved with maybe just 1, but most of the time when I add things that seem to make no sense at all, are actually there for a reason. This one being one of them. I want to make sure that I will never have to think about this when I choose my "Humanize - All" macro.

Then I have the other 3 options, so I also need to add some conditions to those so when I open one of them, I am sure the option I want is visible.

Correct.

Right, I think we're finally getting to what you want to do. I think what you want to do is:

  • Open the Humanize window and ensure all settings are reset to defaults.

Is that right? If so, this does it:

Humanize - All.kmmacros (26 KB)

Macro screenshot

Yes

Well then

When in that case there's no need to add the mouse position actions on your macro

Very true, if that's the end of the macro.

Also, if you just type MIDI it will actually go to the MIDI Region Parameters menu. It needs to be MIDI TRANSFORM