KM is auto correcting springtime to sprinme

When I type springtime it is autocorrected to sprinme. I logged in with Shift key down to disable all my startup items. I first enabled TextExpander to see if it was the culprit. One by one I added other apps that could contain auto corrections. When I enabled Keyboard Maestro the problem returned. Until I quit the Keyboard Maestro Engine the problem does not go away.

I have searched everywhere in my macros for something that would cause this behavior and can find nothing. What setting do I need to fix?

I have not seen this behaivor, and I just did a fresh install of KM on a new Mac.

In the KM app, press ⌘⌥F to engage the KM global search.
Search for these string:

  • springtime
  • sprinme
  • gti

After each search, KM will filter the list of macros to those that contain that string, and each Action in each macro will have a background of blue-grey like this:

The last, "gti" are the characters being removed.
Perhaps you have KM Macro triggered by the typed string "gti".

Here is a macro I just wrote that reproduced your behavior:

Good luck, and let us know how it goes.

3 Likes

Solved!

Found the macro that used shortcut gti and removed. Works now. I would never have thought to look for the removed characters.

1 Like

You can always see the most recently triggered macros in the [⌘] button at the top of the editor window.

So whenever something unusual happens, make it happen and then see what macros have recently fired.

3 Likes

That is an excellent point, Peter. I knew it and should have suggested it. :wink:

That would be a great addition to the Troubleshooting (KM Wiki) article.

1 Like

That would be one option, or I could add a live assistance facility in the editor to answer such questions, something like:

Just an idle thought… :wink:

3 Likes

Hey Peter,

Are you teasing again?   :smile:

Is something like that going to show up in Keyboard Maestro 8?

I think you could save yourself some support time if you added something like that.

-Chris

2 Likes