KM link broken? (Stream Deck 5.1.3)

Anyone else having trouble with KM link and Stream Deck 5.1.3?

Pushing a button no longer executes the assigned Keyboard Maestro macro... :cry:

There have been recent problems as discussed in another thread - check it out:

If this is the cause of your problem then I've already asked the author of KM Link to have a look...

If it's a different problem, you need to say exactly what's going wrong so the author can have a chance of fixing it.

Yesterday I had a macro group stop working from my Stream Deck. Couldn’t figure out why so I disabled and re-enabled it and now it works again.

Can you clarify what you mean by that as KM Link only lets you specify individual macros and not macro groups?

Yea definitely. And my apologies it was still early when I replied which is probably why it wasn’t clear initially haha.

I meant that I have macro groups for specific applications, and corresponding SD profiles for those apps/macro groups. Those profiles contain all or most of the macros from those macro groups.

In this case my macro group for Script Debugger stopped working in the sense that SD was unable to execute any of its macros from the SD itself. For whatever reason disabling and re-enabling that macro group in KM got it working again.

Sorry, seems to be a PEBKAC problem... (i.e., me)

I was trying to invoke a macro in a group that is only active when a certain application is running and I did not have that application running...

Need to re-think my design!

1 Like

we've all been there...

That clears it up, @cdthomer - thanks. I have a similar arrangement too, but have not experienced that glitch (yet!)

1 Like

Update: I am now regularly experiencing problems with KMLink that I cannot figure out the reason nor a solution to.

@corcules were you able to look into this last week as mentioned in this thread?

Hi @cdthomer,

Not yet sorry, have a lot of works this time.

I will but to be honest, i don’t really know what i should looking for at the moment.

Except maybe in the very specific case of the thread you’re pointing, for which the context seems to be quite well defined, i don’t have any information about what your problems are…Please give me some, context, macro, macos/km/sd versions. KMlink is a very simple plugin. I mean that there are not a lot of corners inside where a bug could hide.
So far, the cause of almost every issues reported with KMlink (for those i know) were outside KMLink. Just like your macro group for Script Debugger.

Anyway, i will investigate a bit as soon as i can. KM10 may have change a little some little things here or there…

Yea that makes sense. I was in the middle of a work call earlier so couldn’t provide much info haha. Computer, KM and SD info at end of my post.

Some things I had tried to fix the issue initially were:

  1. Making new KMLink buttons pointing the the non-functioning macros
  2. Making a new SD profile with new KMLink buttons pointing the the non-functioning macros

Neither one of those steps worked however. But I have a theory is at this point. The last few days I've been making a lot of changes to my macro group palettes to incorporate them with BetterTouchTool. I have not purposefully changed anything about their activation status (which apps they're available in for instance, nor their "always activated" settings in the macro group settings), but I noticed now that what fixed my Script Debugger and Apple Music macro groups were changing "Always activated" to "Always activated and shows a palette for one action when:"... for whatever reason both of those SD profiles started working properly again after that change even though they were always active before, as I proved by running them manually and from the menu bar list as well as global macro palette.

That's about all I can provide as of right now. Hopefully it will shed at least a little light on this odd situation. Thanks so much!


Computer info:

Model Name                   :  iMac
Model Identifier             :  iMac19,1
Processor Name               :  6-Core Intel Core i5
Processor Speed              :  3 GHz
Number of Processors         :  1
Total Number of Cores        :  6
Memory                       :  40 GB
System Firmware Version      :  1715.
SMC Version (system)         :  2.46f12
Chipset Model                :  Radeon Pro 570X
VRAM (Total)                 :  4 GB
VBIOS Version                :  113-D0008A14GL-003
EFI Driver Version           :  01.B1.042
System Version               :  macOS 11.6.1 (20G224)
Kernel Version               :  Darwin 20.6.0
System Integrity Protection  :  Enabled
Time since boot              :  2 days 21:58

Keyboard Maestro info:

Version 10.0.2

Stream Deck info:

Software Version:	5.1.3 (14750)
Firmware Version	1.00.012
1 Like

Thanks for all that info Chris :kissing_heart:

During this time, i investigated a bit and made some tests about the other thread issue. And it seems this is the same issue !

And i don’t have any solution. If the macro group is not activated (as configured in the macro group options) when KMLink is triggering a macro that is in that group, KM will not execute the macro. Actually that’s make sense. Until the conditions are met, the macro group is not enabled, so the macros inside too.

So that was not expected behaviour?

If so, my problem was not PEBKAC after all... :laughing:

Well @rob, sorry but yes it is the expected behaviour about KM and so KMLink.

Not sure to understand what PEBKAC means but it seems it was… :crazy_face:

PEBKAC: Problem exists between keyboard and chair.

Like the old 1D10T errors.

1 Like