KM Macros Stopped Responding in Stream Deck

I use KM to run to simple macros.

One that toggle a keyboard modifier key to one setting (Command) and another that toggles is back (CTRL).

I had been using the KM LINK feature within streamdeck to assign the macros to a button, and everything was working perfectly.

Now all of a sudden, the KM macro's do not run when I press the button.

I've tried deleting and re-assigning in the Stream Deck app.

When I open KM and run/test the macros there, they still work as usual, but for some reason, the KM LINK feature seems to no longer work with Stream Deck.

I've restarted the system, both apps, and have deleted and assigned the macros in Stream Deck.

Any suggestions would be greatly appreciated

Did you update Stream Deck?

Also – try removing the USB connection and reconnecting it again.

Nothing was updated (at least manually).

The rest of the buttons on the Stream Deck work. It's only the two buttons that use the KM LINK option.

I tried to make a new macro in KM, and assigned it to a button and it's it's not working either.

Doesn't seem to be the Stream Deck, rather only the buttons that have KM LINK assigned.

Everything was working fine and all of a sudden KM buttons stopped working.

I though maybe it was cause I hand't purchased/registered KM, so I went ahead and did that. Nothing changed.

Try updating Stream Deck.

Not really an option...

I would need to to upgrade my OS to update Stream Deck software any further.

Again, nothing changed on my system.

Stream Deck is working fine for all buttons, macros, multi-actions etc other than the ones using KM LINK.


Quit the Stream Deck app; don’t just close its primary window.

Then, unplug it from the computer.

Then plug it back in.

Then restart the software.

Every single time I’ve had the issue you’re describing those steps have fixed it.

If that doesn’t work, try a reboot as well.


If you are using KMLink, then as far as I am aware it works by simply asking Keyboard Maestro to trigger the macro via AppleScript.

Try the Interactive Help, Something expected is not happening, and see if it indicates any problem with the macro not being enabled and active.

Other than that, and restarting obviously, I'm not sure what else to suggest.

1 Like


  • Some people have that kind of issue because of the rights access, mainly after an OS update.
    • Check that in system preferences or try to delete KMLink plugin, restart and reinstall the kmlink either from the Elgato store or from GitHub release.
  • Have you try to use the regular KM for Stream Deck plugin ?
  • Can you try to launch a macro from Stream Deck with AppleScript ?
  • If your macros are inside folder in KM, check folder’s settings. For example, an active macro would not run if it is inside a inactive (for some reason) folder.

New Stream Deck – KM Link Not Working - #10 by corcules

I don’t see anything else at the moment…
Let us know.