macOS 12.5.1 and Keyboard Maestro

Hi! My work computer updated to 12.5.1 and suddenly Keyboard Maestro Engine won't open anymore.

Same thing with the "Launch Engine" menu bar item in the main app (but that doesn't show the error).

I've tried applying a few variations of xattr -rd /Applications/Keyboard\\ Maestro\ but still doesn't work.

Even downloading Keyboard from the website was giving my trouble:
CleanShot 2022-08-22 at 14.24.59
but brew reinstall or xattr -dr "/Applications/Keyboard" fixes opening the Editor but not the Engine.

I found on the Editor logs:

2022-08-22 14:30:36 KMApplication::LaunchEngine error Error Domain=NSCocoaErrorDomain Code=259 "The application “Keyboard Maestro” could not be launched because it is corrupt." UserInfo={NSURL=file:///Applications/, NSLocalizedDescription=The application “Keyboard Maestro” could not be launched because it is corrupt., NSUnderlyingError=0x600003db1fb0 {Error Domain=NSOSStatusErrorDomain Code=-10827 "kLSNoExecutableErr: The executable is missing" UserInfo={NSURL=file:///Applications/}}}

I've exhausted my bag of tricks to make it work. :frowning:

Confirmed here. Unable to use KM on 12.5.1 and reinstalling does not fix the problem.

Looks like the new security changes in macOS have broken things.

I have a new install of Monterey (12.5.1) running with Keyboard Maestro 10.2 (the new release). Standard installation (not 'brewed') for Keyboard Maestro.


What's the output when you run the following in Terminal?

spctl -a -vvv /Applications/Keyboard\\ Maestro\

I've just been through something similar with another software's Support -- if it's the same it isn't KM, it's a problem with the OS update.

Hopefully @peternlewis has a better solution than the people I was talking to -- I ended up having to wipe and clean-install the user's machine, restoring only their home folder and nothing from /Applications or /Library.

I forgot to update the thread after emailing support.
The issue seems to be SentinelOne which I have on my machine (work laptop). It immediately quarantines the Engine when downloading the app.

spctl seemed happy to accept the file as correctly notarized, so I tried restarting KM once more but this time with Console running. There was a flood of errors about invalidated assertions, missing plugins files and bundles needing to be set launch-enabled, then it eventually popped up a dialog saying that an update was available and having accepted that, it now seems to be running.

I suspect that the security changes in the 12.5.1 update invalidated something in the engine security config that is only being rectified by the just released 1020 KM update, since a manual re-install of 1011 didn't seem to do any good previously.

That's a relief. I had to do 4 wipe/reinstalls last Friday -- while at least another dozen machines with the same software and upgrade were totally fine! -- and I wouldn't want to put anyone else through that...

Yes, unfortunately SentinelOne actively breaks the Keyboard Maestro Engine. My attempts to get them to stop doing this have so far failed. Please do report it to them, as a report from a customer might be taken more seriously.