macOS 12.6 breaks 'Select or Show a Menu Item'?

It seems that macros that access an item in an application's File > Share menu stopped working with the macOS 12.6 update that was released yesterday (2022-09-12). I assume this is a permissions issue, but I think Keyboard Maestro still has granted all of the accessibility permissions that are normally required.

For example, I have a macro that selects the menu item in Safari: File > Share > GoodLinks. KM can no longer see any items in that menu. If I tried to edit the macro action using the 'Menu' drop down to select a target, but KM doesn't show any options in the File > Share menu.

This menu seems to be no longer be accessible by KM across a handful of other applications that I've tried, such as TextEdit.

Is there a specific permission that should be reset to allow KM to access File > Share menu items?


Hey Aaron,

I'm on 12.6 and I just set up a macro to do the select Goodlinks from the share menu and it worked without any issues. I would check that GoodLinks is enabled in Safari preferences ---> Extensions

Hey Aaron,

MacOS has a perennial problem with the shared items menu.

It's dynamically created, and if you have not opened it at least once the macOS tends not to see it.

Since I don't have macOS 12.6 I can't confirm that this is the problem you're seeing, but the fix I commonly use for this type of problem is thus:

  • Use a choose menu action to open the share menu only.
  • Use a pause action to let the menu populate.
  • Use another choose menu action to select the target menu item I want.

This methodology is not a panacea, but I've found it often solves this particular type of problem.



Thanks larsof54; GoodLink was enabled in extensions in Safari.

Thanks ccstone, your recommendation to add actions to activate the File > Share menu, add a delay, then select the target File > Share > GoodLinks worked as soon as I added it those two additional actions.

I just had never run into this even though I have several similar macros that select something in the File > Share menu. So this is a good trick to know. Thank you.


Thank you for this!!
I was having trouble with the Services menu. I had to type my trigger twice to make the macro start. Now I doubled the menu action and one keystroke does the trick as it should.

1 Like