MACRO: [KMFAM] Favorite Actions and Macros

search
tools
workflow

#181

So to elaborate, this is odd behavior. I just got it to work a couple of times by selecting a group but making sure all of the disclosure triangles were open for each action. I added a couple of "actions" successfully (grouped actions named as one action). Then I went in to clean up some of the old ones and just decided to delete everything from my favorites and start fresh. Then I did the same, made sure disclosure triangles were all open, selected the group, pressed my shortcut key, now I'm back to the error I was getting before.

Screenshot of the error: 41%20AM

If you could advise how KMFAM is supposed to handle grouped actions, it would be greatly appreciated.

With Gratitude,
Brevig M.


#182

There could always be a bug, but nobody else has reported this. If you could make an animated GIF showing the error occurring, it would help diagnose the problem.

Here's a "favorite action" that has two actions selected at the same time:

Here's a group:


#183

Oh, and here's one with the actions closed:


#184

I can confirm @DanThomas' statement that saving multiple selected Actions as one KMFAM "action" works fine. I do this all the time.

Exactly how did you do this "clean up" operation?
Since your problem started after this I suspect that something you did here is causing problems with adding new KMFAM actions.

@DanThomas will have to advise you how to work through this, but he will need to know what you did to "clean up" KMFAM.


#185

Thanks for your quick response.

I initially thought it was an issue just with large "actions" that contained several levels of nested groups, but I have even gone in to the lowest level within the group and tried to add a single action from within the group and I still get that error message. I also just checked again and I'm even getting the error on a single action that is not nested within any groups.

I am unable to provide the screen recording due to confidential information within most of my named actions (large corporate employer, can't take any risks). There's really not much to it though. I select the top level action (usually a group of actions that I grouped using the "Engroup" feature in Keyboard Maestro, and usually several nested layers of grouped actions), then type my shortcut keys for [KMFAM] Add Action(s) (which I set to Cmd+F12), and then get the error pop up that I provided in the screenshot in my previous post.

I just did a complete re-install of Keyboard Maestro, then re-install of KMFAM. Issue persists.

I'm so frustrated because I know KMFAM has worked for me in the past, but it's been a while since I started getting this error. I haven't built a lot of new Macros lately, so it wasn't affecting my workflow until now.

I'm also getting the error on more than one computer.

I'm using Box Drive to sync macros across a few computers, and I told the KMFAM Resources folder to live in a Box Drive directory as well. Could that be somehow affecting KMFAM's functionality? I wouldn't think so, but I'm grasping at straws at this point.

If there's any other information you need to try to determine what might be causing this, please let me know. If I'm the only one having any issues with this then it's obviously got something to do with my setup, but I just can't figure out what that would be. I'm going to try a fresh install of Keyboard Maestro again, then re-install KMFAM. I'll try to build a few without syncing through Box to see if I still get the error.

I appreciate you taking the time to look into this.

-Brevig


#186

I did another removal and reinstallation of Keyboard Maestro, then reinstalled KMFAM and did not sync with my Box folder. Everything is local. Even now, you can see in the screen recording that I can't even add a stand-alone action using the [KMFAM] Add Action(s) macro. Not sure how I broke the functionality of your amazing creation, but somehow I did.

KMFAM%20Error


#188

[edit] I forgot to say "thanks" for the animation. It helps a lot to show you're not doing something wrong.

I wonder if it's something as simple as a timing issue? There's a "pause" you could adjust, but let's make sure this is where the issue is.

In the macro "[kmfam]~Add (Sub-Macro)", add a Prompt as shown in the purple action here:

image

Then try and add a Favorite Action. If the Prompt doesn't appear, then this is probably where the problem is. Obviously, delete the Prompt when done. :stuck_out_tongue: (If the prompt does appear, click Cancel and let me know.)

Assuming this is where the problem is, try making the Pause action there a little longer, and see if it helps.

image

It shouldn't need to be much longer, but fiddle with it and see if it helps.

There's actually a better way to wait for a Copy to finish, but I didn't know about it at the time. But let's not muddle the issue for now.

If this doesn't solve the problem, we'll figure this out, if you're willing to do a little debugging. I've been really busy the last few days, but I have the time (and patience) now, so we'll get the job done. I'll be in and out for most of the day, so I may not respond instantly, but I will respond.


#189

Thank you so much for taking the time to look into this for me.

I feel like an idiot, but I think I figured out the issue. I did what you suggested, but was still getting the error. It was inconsistent, like sometimes it would get to the user prompt that I added and sometimes it would throw that error. I started thinking really hard about the error itself.

"You must select one or more actions first."

What could be causing it to think that I don't have an action selected?!?!?

It shouldn't have taken me this long to figure out, and I apologize for wasting your time. I'm almost 100% sure that the issue was caused by the clipboard manager application I am using called "Copy 'em Paste." I've been using that since before I started using Keyboard Maestro, and while I know I could probably get the same results using KM instead, I'm familiar with the workflow for the other app so I have continued to use it. I swear I have added KMFAM actions in the past while Copy 'em Paste was running, but perhaps if I was to track the timing of when my issue started it would coincide with an update to Copy 'em Paste that made it handle something differently.

Anyway, as embarrassing as it is, I figured I would come post this with my tail between my legs just in case anyone else runs into a similar issue.

Thanks again for your help. I really can't thank you enough for spending the time to suggest a fix for my individual issue.


#190

That's nothing to be embarrassed about - that's the kind of thing I'm impressed you figured out. Program interaction is really hard to suss out. I use GIMP a lot, and when KM's clipboard manager is running, the second time I do a copy from GIMP, GIMP crashes. That took forever to figure out. I've got KM set up now to turn off the clipboard manager when GIMP is running.

I understand why you use that app. I use SnagIt, and I love it. Once you get used to using apps like these, there's no way to stop using them. By the way, if you do need to try something else, try SnagIt. The editor is fantastic (for what it does).

Glad you got it figured out, fingers crossed. :stuck_out_tongue:


#191

Hey Brevig,

Don't be too embarrassed. Troubleshooting is rarely easy.

But – learn the lesson.

One of the primary troubleshooting steps is to turn off any and all utilities/applications/extensions that might be altering the way the macOS behaves.

It's also a good idea to have a troubleshooting check-list, because most people don't do it very often and need reminding of the steps.

-Chris


#192

Chris - You're right. But how do we find all of these utilities/applications/extensions? For example, my new iMac's speakers don't work, and I suspect it's an old piece of software that came over from my Time Machine backup, but I have no idea how to find out what it might be. So how do you find all of these things that get loaded at startup?


#193

Hey Dan,

The first place to look is is in System Preferences > Users & Groups > Your User > Login Items.

You can do that by hand.

You can also get the list via AppleScript:

set AppleScript's text item delimiters to linefeed
tell application "System Events"
   set loginItemList to (name of login items) as text
end tell
return loginItemList

Somewhat less reliable because of caching in the macOS is this:

# macOS Sierra 10.12.6
plutil -convert xml1 -o - ~/'Library/Preferences/com.apple.loginitems.plist' \
| egrep -A1 -i '<key>Name</key>' \
| sed -E '
   s!^[[:space:]]+|--!!g
   s!<[^>]+>!!g
   /Name/d
   /^$/d
'
In OS X 10.8.6 it updated the following file:

~/Library/Preferences/com.apple.loginitems.plist

In macOS X 10.13.1 it updated the following file:

~Library/Application Support/com.apple.backgroundtaskmanagementagent/backgrounditems.btm

This is fairly old but still relevant:

How's that for a start?  :sunglasses:

-Chris


#194

Thanks, Chris! Great stuff, and it did help, in a strange roundabout way. I think it was the Macworld article that recommended "launchctl list", and when I finished BBEditing the list to sort it and remove dups, etc, I found at least one questionable item.

People seemed to trust Malwarebytes, so I downloaded that, and it found a handful of things to remove. After doing that and rebooting, I suddenly have my speakers back!

So, I don't know which one caused the issue, and frankly, I don't care. Suddenly, I can hear again!!

Thanks again. It's nice to know smart people. :stuck_out_tongue:


#195

Dan, the other biggie Chris didn't mention is:
Use safe mode to isolate issues with your Mac

  • Verifies your startup disk and attempts to repair directory issues, if needed
  • Loads only required kernel extensions
  • Prevents startup items and login items from opening automatically
  • Disables user-installed fonts
  • Deletes font caches, kernel cache, and other system cache files

Then launch ONLY the app/util that is having the issue, and test.
Then start each of the suspected apps one by one until you find the culprit.

I have found this very helpful.


#196

Thanks! I'll remember this for next time.


#197

Hey Dan,

I don't have anything nice to say about Malwarebytes...

  • It's egregiously expensive for how limited it is.
  • It's ugly and un-Mac-like.
  • It can't be turned off – you have to uninstall it.
  • I just tried it again, and it quarantined something when I forbade it to do so.
        - Luckily it was junk-ware I didn't need.
  • It has no keyboard shortcuts for basic operations.

Malwarebytes' antecedent Adware Medic by contrast was written by a Mac guy who kept it free for years, and it was quite a spiffy little utility.

Personally I use the free version of Bitdefender Virus Scanner and run it manually once a week and sometimes on-demand with downloads I want to check.

When I get my new Mac (with buku memory) I might just use the full version.

Excellent! Glad you've gotten things working.

-Chris


#198

Interesting! I did, in fact, uninstall it when I was done with it because, as you said, I couldn't just turn it off. I'll have to look into Bitdefender. I've never worried about this stuff before, on my Mac. I suppose it's time to rethink that.

Thanks.