MACRO: [KMFAM] Favorite Actions and Macros

search
tools
workflow

#141

I am humbled and honored to accept this doctorate, and in the future, please refer to me as Doctor Dan!

In all seriousness, you guys are crazy, but I really do appreciate the love. :blush:

Here’s a smaller image, for those interested:


#142

Hey Dan! Hope you’re doing well.
No ideas at the moment, other than maybe it was not installed properly.

@ajg23, it is hard to diagnose from your brief description.
I don’t know what you mean by “if I accept the default location, the support files are in a temp folder”.
I’m pretty sure that is not the case, else the installer would not work for anyone.
Perhaps a screenshot of this would help clarify.

May I suggest that you do a clean reinstall of KMFAM:

  1. Delete all KMFAM related macros in KM
  2. Delete all KMFAM related KM Variables
    • If you type in “kmfam” in the Search box in the KM Preferences Variables tab you should see them.
    • Select all of the variables, and click on the delete button (image)
  3. Delete all KMFAM files you have downloaded
  4. Restart your Mac
  5. Re-download the KMFAM installer zip at the top of this topic.
  6. Carefully follow the instructions.

Good luck, and let us know how it goes.


#143

Okay, this is what I did before except for doing the variable deletion. I was really hoping that would work because I happened to noticed that the KMFAM variable path location contained just the name of the variable (instead of the path).

However, got a different problem this time. Before, it had a link to a temp path at the bottom of the install dialog, and indicated I could click that to change where the resource folder would go.

THIS time, it didn’t propose a folder, it just gave me a dialog requesting a location:

And after I chose the location, I got this:

Same thing if I chose “Desktop” as the location!

WEIRD: tried a couple times with different versions of the install file (though they were identical); sometimes I got this request to point to the installer app:

When I navigated to the installer (as shown above), I FINALLY got to where I was before:

…however, as you can see above, this time the link at the bottom of the installer window CORRECTLY points to the selected folder (rather than an arbitrary temp folder). Huzzah! :slight_smile:

However, while typing the above, it threw an error saying an event timed out so had to start over–and now I’m back to getting the error I got before :stuck_out_tongue: …Just getting the “Macro Installer Error” dialog on multiple tries, including from multiple “versions” of the installer app. Tried quitting KM engine and KM editor and running again but still same error:

Ah: FINALLY decided since it is saying “file not found” in the installer package I should try moving the installer somewhere else -> moved to desktop and it WORKED. :crazy_face:


#144

So, is your problem resolved, and KMFAM now working for you?


#145

I’m sorry - I thought you had already tried that. If you had posted a picture of the error message, I would have realized right away what the issue was. This is due to something Apple is doing now, where they think they’re “helping” us.


#146

@JMichaelTX, yes it’s working!

@DanThomas, yeah, it was bad not to post the error–I put off posting about it so it wasn’t available, and I was lazy :stuck_out_tongue:

Thanks all as always for the help!


#147

@DanThomas I've been trying KMFAM and have a problem. I use F6 as the default key. I press F6 and type in a word, no result, so press F6 again - the resulting window appears in the lower left of my screen showing only the top right quarter of the window. I can't move it with the mopuse or any other way I've tried. Any ideas how I might fix this? Thanks


#148

Open Keyboard Maestro's Preferences dialog, and click on the "Variables" tab. In the search box at the bottom, type in "DND__kmfam". Delete the variables that say "WindowPosition". DON'T delete anything else.

That should fix it.


#149

That did indeed fix it, many thanks for your prompt reply.

Cheers

Pat


#150

Awesome! And you're welcome. :slight_smile:


#151

Hi Dan, this has happened again with the window down in the bottom left-hand corner of the screen. I know how to fix it now but have you any idea how I can stop it happening? Thanks.


#152

That's really odd. It shouldn't be happening. (duh)

The only thing I can think of is to modify the "[KMFAM] Select" macro.

Add ONE of the actions in the red box, below:

The variable name is "DND__kmfamWindowPosition".

That will at least work around the problem.

Let me know how it works for you.


#153

Thanks, Dan. I've added the first one to the macro and all seems fine at present. I'll let you know if anything untoward occurs again.

Cheers
Pat


#154

Thanks for letting me know. Everything should be fine now. The only other thing I can think of is that another macro is modifying that variable, but I can't imagine why it would.


#155

I've had this happen too before, but with the insert action by name box, not KMFAM. I always just work through it. I can duplicate it by Activating that box, and activating it again while it is still open. :man_shrugging::sweat_smile:


#156

Well, don't do that! :grinning:


#157

Just talkin' out loud :upside_down_face:


#158

Patient: "Doctor, it really hurts when I do this. What's your remedy?"
Doctor: "Don't do that!"

Sorry, Dan. A bit of fun at your expense.

But of course, Dan is correct.

Dan has cleverly used this action at the top of his KMFAM Macro to prevent running it a 2nd time while the first instance is still running:

image


#159

Jim, that's exactly what I was referring to - the old Henny Youngman routine. One of my favorites.


#160

Is there a way I can do something similar to avoid my issue with the Insert Action by Name text box? I trigger it with a hotkey: