Move at found image - Is hit and miss for me

Move at found image is very hit and miss for me.

For example, here is a move at found image that works on the formatting icon in Gmail:

Even though the icon is very tiny and very vague, it works perfectly!

Here is an image taken from Affinity Publisher:
This doesn't work at all. Even when I use "in area" option and also change the fuzziness, it just doesn't work. Even if I change "unique", to "best", it still doesn't work.

Here is an image taken from PublisherRocket
This image is much bigger. And it doesn't work. As before, i have tried various options, but it doesn't work.

I have followed the wiki instructions and made sure Keyboard Maestro editor is hidden when running the Macro. But it still doesn't work.

Is there anything I can do to make it work more consistently?

I have several tips and questions for you. I have a ton of experience with Find Image, but I can't say that I know everything about it.

If we could see your Find Image action or condition it might be easier for us to help. For example, we might spot an action parameter that you're using that is causing the search to fail.

One troubleshooting approach is to always enable the "display" option in the Find Image action or condition. And here's a tip: you don't even have to run the action, you just leave it visible in the editor window and if Display is checked off you will see exactly where it sees all copies of that image. In fact the actual fuzz factor number is displayed over each found image. That helps to set the correct fuzz factor value. It's really cool how that works.

Another technique when I use Find Image is to turn the Engine off and on again. Sometimes that helps. For all I know, you may not have rebooted the KM Engine in weeks. That may not be the case, but I can't tell if it's the case for you. So I have to suggest it.

Another technique I use for this problem is to re-capture the image and place it back in the Find Image action. Sometimes this fixes it. I have no idea why.

Find Image works best with multiple colours and fewer solid colours. Your images have a significant quantity of solid colours. If you have something a little more colourful an inch to the left or top of the images you are searching for, that could help a lot. One time I tried writing code to report to me the locations of all the squares of an empty chess board, and it was not able to do that because it really was not able to find solid colours very well. one of your image almost looks like a chess board. I see online there are some images of these apps and some of these apps have coloured icons in part of their interface. If you provide a wider image showing the fuller page rather than just the piece of the image you are searching for, I may be able to give you some helpful advice on this.

Some apps have choices of colours for the user interface (dark, light, and sometimes more). Are you willing to try a different colour option and test it that way? I'm not saying that's the correct solution, I'm just saying that might help with troubleshooting this.

P.S. I was successfully able to search for and find the images you posted. So that means under the right conditions those images can be found.

1 Like

Thank you so much for your help!

Here they are:

In both macros, the find image is the only action. At thought at this stage, it wouldn't be worth adding anymore steps until the image is found!

I try this, but it doesn't seem to do anything. However, on the Gmail one which does work (which I provided in my original post), then the fuzz number does display.

I tried this, but it doesn't work. I actually restart my computer several times a day anyway.

Here are the full-screen images (Because they are full screen, I have linked to them)

The publisher rocket app doesn't have this. The Affinity one does, but changing didn’t seem to make any difference.

Interesting - does that mean there is something wrong with my KM set up? Do you think reinstalling might help?

Agreed. But in this case you are using Unique instead of Best. Change that back to Best.

When you changed colour schemes did you then change the image you were searching for? And when you changed back did you refresh the search picture with a new image? I think that was the most important tip I gave you and you made no mention of it in your reply. I said this:

It's vital that you try that.

I don't think we need to go that far yet. I think right now the most important thing is to take a re-capture of the search image as one of my suggestions indicated. And the next step is for me to examine those larger screenshots. I'll do them right after I post this comment.

EDIT: Okay the first screenshot which contains the word "transform". This image seems to be in the lower right corner in the same position. If that's true, you don't need Find Image at all. You can click relative to the lower right corner of the current window. I know you prefer Find Image, and I expect we can get that to work, but this alternative should work faster and more reliably, if the image is always in the same lower right corner.


The numbers -55 and -55 are numbers you have to manually calculate using your mouse and the screen. Use whatever negative numbers move you up and left from the bottom right corner.

As for the other search image, the keyword search one, it seems obvious why that one isn't working. Because the image you are searching for has a blue bar on the top but in the full screen image you provided it's a huge red bar. That would cause it to fail. I can only go by what I see, and what I see is the wrong colour. This is why I said it was "vital" to take a re-capture when something like this isn't working.

Let me know how these two changes work. plus the change of "Unique" -> "Best".

1 Like

Thanks for your help. Sorry, my last message was a little sloppy. I did try creating re-captured images after changing the colour, but it still didn’t work. And I had tried switching between unique and best. I also tried creating new captures for everything and still didn’t work.

Oddly, today, I have started using it (without changing anything) and it's all working fine. It's very strange. I think something like this might have happened a few weeks ago too. Yesterday when I had the problem, I had restarted several times after the problem, and it was still occuring, so it's odd.

I've got some more found by images macros to make, so if the problem occurs again, I will post back.

Because the image you are searching for has a blue bar on the top but in the full screen image you provided it's a huge red bar. That would cause it to fail. I can only go by what I see, and what I see is the wrong colour.

Hmm... The full screen image looks blue to me. Maybe somethings up with my monitor/colour profiles?

Okay. Great. My guess is restarting the KM Engine fixed it.

Hmm. Very curious. I like mysteries. Mysteries often reveal deep and unexpected truths. I'll ponder it but I don't know what might cause that.

1 Like

The Find Image facility will not work well with images like that that have little contrast. They are too close a match to most of the screen.

Unless you can restrict the search image to a small area, it simply wont work well with a grey image like that.

If at all possible, try to find some other image that has a fixed relative position, and that includes some amount of color in it, so that the Find Match system has a reasonable hope of finding the correct match.

I figured out what the issue is. Somehow in the field for "move mouse at" the fields had become empty. I put in a zero and it works. I can't believe I missed that! >_<