Multiple Selection With Keyboard in Prompt With List Action

For me keyboard & trackpad already works!! It doesn't seem to make a difference between the mouse and them.

Awesome! Thanks so much! Everything works great :slightly_smiling_face: It's just that the esc key doesn't work for me somehow. What works is that I have to click the trackpad outside the prompt field and the macro immediately shows the selected items.

Same holds true when I press CTRL-SHIFT-F6! Macro 1 then also show the selected items. Maybe I'm doing something wrong here?

Apart from that, everything works really great :slightly_smiling_face: Thanks so much again for your time and help. And please take all the time to get back to the esc issue!!

I'm happy that you're happy. But I'm unhappy that you're not completely happy. Anyway, I need time to make food and such, so I'll come back later and reconsider the problems.

1 Like

Haha! Sure! Enjoy! And thanks again for your time and help :pray:

When I press Escape, it displays the results that I've selected up until that point. Is that not what you are getting? Is that not what you want? If you aren't getting that, we should investigate. Or maybe tell me why this isn't what you want.

When I press CTRL-SHIFT-F6, Macro3 (not Macro1) will display the selected items, if there are any items selected. Is that not what you are getting? Is that not what you want? The Macro1 macro does not stop when I press CTRL-SHIFT-F6. I thought that's what you wanted.

You are using a trackpad. Im not sure how you RIGHT-CLICK with a trackpad. Could that be the problem?

So from everything I can see, the macro is doing what I intended. If it doesn't match what you want, please try to explain again what it should do.

Hi @Sleepy

Thanks for getting back! I hope your dish was good :slight_smile:

Everything is working perfectly! I have just no idea what's the issue with my esc key. I actually found out that the the macro stops when I press the "fn" key + the "esc" key- which is really strange. This doesn't happen when I just press the "esc" key. So, I guess that's something with my keyboard?

Edit: The "fn" + "esc" issue is definitely a problem on my side. It's the same for another macro! :thinking:

I don't have any experience with the laptop's FN key, but there is a FN key on my iMac keyboard. Why are you pressing it? You didn't mention needing to press it until now. I can modify by app if I know what your intentions are.

Thanks so much @Sleepy !

I figured it out. There was something strange in my BetterTouchTool settings! Everything works now!! Thanks so much again :slightly_smiling_face: :pray:

It was my pleasure. It was fun to get the Prompt List action work with single clicks.

1 Like

Yeah that's insanely cool :slightly_smiling_face:

Hey @Sleepy, thanks for the macro's. The current selection displays in lines below each other. Is it much trouble to have the result (selections) displayed inline.

Item2 Item4 Item6

Tried to solve by adapting tr "\n" " " without result.


Replacing "\n" with "," is a problem I face approximately once per month and I keep having to re-solve (not resolve) it because I keep forgetting what my solution was. Give me a few minutes.

Ok , that line of yours should work. I tested it. I replaced the last line in my Macro1 with the following, and it displayed what you wanted:

Why didn't it work for you? What error or result did you get?

@Sleepy Thanks for your reply and solution. I tried also tr -s "\n" " " and tr "\n" "\b"
problem was that I placed it on de the wrong place in Macro 1.

Hey @Sleepy, I also use variables in the Items list. Unfortunately these are not translated to the value of the variable as it does in a prompt list. Any way to solve this?

If you are talking about the action "Prompt with List", there are four fields in that action. Which field are you saying "does not translate to the value of the variable"? I've successfully used variables in each of these fields. It would help me to understand if you showed your code.

@Sleepy, regards Macro1 action

The variables LST_Item1 and LST_Item3 are alrdy set.

When I insert a variable into a Set Variable as Text action, it substitutes the variable. You can see that in the highlighted red square in this image. Text substitution works. So my suggestion is that you provide a more complete example of your problem, or insert debug statements before and after your macro to ensure that the variables are set to what you think the are.

@Sleepy, not getting the same result

I'm very curious. I'm studying your image now.

My first theory is that it MIGHT be a typo. The letter "l" and capital letter "I" look identical. Please retype everything while I consider other possibilities.

same in prompt list gives desired: