Named clipboards: how to change font and background color, font type, size etc

I find that named clipboard are a clean and efficient way to display information (text or charts or keyboard shortcuts) for quick reference, but the font size is too small, the grey background makes reading more difficult, etc
thanks in advance for your time and help

Hello @peternlewis .

Sorry to bother you. I recently re-discovered names clipboards and find them very useful as quick reference panels to display information.

Compared to Display Text in Window, named clipboards are "cleaner" (no "box" around the text) and quicker to close with a simple spacebar tap.

My problem is that the background of named clipboards is grey forcing me to first convert text and tables to white font (with variable results in terms of readability) before pasting to a named clipboard, or else to convert everything I paste into a named clipboard to images first.

Is there a config file that I can edit to change the named clipboard background color from grey to white ?

thanks very much

Which grey background are you referring to?

1 Like

Ventura 13.6.6. KM 11.0.2

If I trigger the action "display named clipboard", (1) a grey panel is displayed (2). In that grey panel, I want to paste and display all kinds of information.

My problem is that the background is grey, and except for images, if I want to paste styled text or tables in a named clipboard, the text must be white for the Named Clipboard to be readable

Example: I pasted styled text into a Named Clipboard (3) which is the normal black on white. When I trigger the corresponding display named clipboard action (4), the background is grey and the foreground white which is inconvenient and unpleasant to read.

I have the same result with 2 methods: if I paste the text directly into the Named Clipboard via settings → clipboards or if I use the Copy to Named Clipboard action

thank you @peternlewis

I tried to duplicate it, but I get this:

So I'll need more information on exactly how to duplicate it. It might depend on where the text is coming from, or the exact styles of the text?

1 Like

I'm 90% sure that the reason you are seeing different things is that you have this setting set differently:

1 Like

I have the same setting

your background is black (probably working in dark mode?) and mine in grey (I am working in Light mode), but the issue I describe is the same. You have to use a white font to make the text readable, which is a pain to have to reformat all text to suit the named clipboard's background.

are you able to create a named clipboard that once displayed looks like below: black text on whitish background.

example of what I would like to see. black text on white background

I am working in light mode

If you have time, could you create a named clipboard, paste a bit of text in it (normal black font on white background) and display that named clipboard. ONLY IF YOU HAVE TIME which you probably don't which is no problem. thank you.

@ronald, I've been following this discussion and I have already tried what you've suggested to @Airy ...

My Mac is set to light mode, but my named clipboard display has a black background and not grey like yours. When I paste ordinary text in, it appears as black on the black background, so is not visible until I, for example, select it.

1 Like

@tiffle @Airy @peternlewis

So @tiffle , you are in a way confirming that there is a problem.

in the meantime, I just found a workaround which is the precede the display named clipboard with an apply style to named clipboard action.

I'm trying to respond to your question, but every time I post my response, this website gives me an error that my message is "too similar to something I posted recently" and refuses to let me post.

Nope, I'm in light mode.

As I suggested earlier, I suspect it depends on the format and application you are copying from.

“ordinary text” - how? From where?

Text is either plain, or styled. If it is plain, then it should display white on black in the display.

Styled text on the Mac is a whole big basket full of worms that behave differently in different applications.

If it is styled, then it should display somehow, but exactly how will depend on the styled text. For me, it displays properly in the cases I have tested, so I will need to know formatted text is being copied from where.

Text from this discussion as seen in Safari. Just selected, copied and then pasted.

Me too, yet my results are like @ronald's:

It's not entirely obvious in that screen shot, but the background is semi-transparent -- you can see the "bleed-through" of the KM Editor window in @ronald's number 2, above.

copy paste section of this forum in Chrome into the named clipboard

If it's text, you could can avoid the issue (I think) by sending it through the Filter > Remove Styles action before putting it on the named clipboard. At least in theory that should work :).

Of course, this doesn't help if you want the style....


1 Like

unfortunately, it does not change anything. The only temporary solution is to apply style. thank you for giving the problem some thought.

(click to expand/collapse)

OK, so it happens when the text has a foreground color but not background color. Should be fixed in the next version.


thank you @peternlewis !