Need Help Clicking & Dragging Column Headers in Final Cut

@JMichaelTX, @ccstone, @ComplexPoint, @peternlewis

I've done a lot of searching, and I suspect that I'm out of luck here, but I thought I'd give you geniuses a chance to see if you've got any ideas.

I'm trying to automate clicking and dragging a column header in Final Cut's clip browser. It just won't drag the header, no matter what I do. The column header changes color to show that it is, indeed, being pressed down. But it just won't move.

I tried separating the button down, move, and release actions, with some "Pause"s. I tried moving a small amount at a time. I tried "Set Action Delay".

Any ideas? Thoughts as to what I might be missing? AppleScript or JavaScript suggestions? UI Browser-type suggestions?

TIA

Hey Dan,

I'd try two things.

  1. Separate click-and-hold and move into asynchronous sub-macros.

  2. Look at the column header in UI Browser and see if there are any settable Properties or Attributes.

-Chris

That's an interesting idea. Why do you think asynchronous sub-macros might make a difference? I'm asking because I want to know what you're thinking here - it might help me think of other ideas too.

You know, I thought I had done that, but now I'm not sure, so I'll look again. Thanks!

Looks like I solved it. I did a Mouse Button Down, followed by a loop moving the mouse 50 pixels at a time until it got to the destination, then released the mouse.

2 Likes

Sometimes Keyboard Maestro gets in its own way, and sometimes you can get around that with an asynchronous sub-macro.

-Chris

1 Like