Need help with Shell Script, GREP, KMVAR

Regarding "how you did this" I can only guess that you accidentally pulled down the menu and changed it. Or maybe you created this by having a "default action" for "Execute Shell Script" in which this setting was changed.

Regarding "where the global default would be changed", there is no explanation for that in the page cited above, but as I said, if you created this action from your favourites, you can effectively change your "default" because your favourite can be set to any option that you want. So tell me, is the Execute Shell Script action in your Favorites?

thank you !! I did create a new macro and added an "Execute Shell Script" action and it did have the "include all variables" checked.

My guess is that I had copied a ESS action from a macro previous to KM ver. 11 when "include all variables" was not a default.

again thanks.

It is not. but see my other reply.

Yes, I see. In any case, it works and we know why it didn't earlier.