New to Keyboard Maestro, strange issues with command keys

First, I have no idea if this is a Keyboard Maestro issue. I have two computers, and K.M. Is only installed on one of them. That's whats making me think it may be related, as it does not happen on the other computer.

K.M. is not set to run on log in. There are no scripts that use "Command n." There are also no built in keyboard shortcuts that have taken over Command n.

My problem is this: When I'm using any application (could be a Microsoft app, Safari, any other web browser, etc), Command m (new document/window) no longer works. It's grayed out in the menu bar, so I can't quickly start a new email, Word or Excel doc, etc.

Modified command-n works just fine, as in create a new folder in a Finder window with shift-command-n.

Could this be a K.M issue, or am I looking in the wrong place?

If KM isn’t running it won’t be affecting anything. It’s well behaved in that regard.

Your question may have implied this already, but I'd like to be sure, do you see the following icon in your system menu when the problem occurs?

Screenshot 2023-11-17 at 13.30.14

Also, I think there's a typo in your question, when you wrote "Command M" I think you meant "Command N." It took me a minute to recognize that.

Yes, the command icon is there. And yes, I mean command N not M.

But the issue doesn't change with KM is not running, so I'll start looking elsewhere.

I think you need to check what is the default folder that Pages uses to save its files. This is because CMD-N gets greyed out if Pages cannot write to the default folder. The default folder is set to the last folder that you saved a file to. If that folder no longer exists, or is a network folder, or is a folder that you no longer have permissions to, then you need to find a way to overwrite the default by opening an existing file with Pages and saving a copy of it to the folder that you want Pages to use as your default folder.

Of course, there might be other reasons why CMD-N is greyed out, but this is one of the reasons, so you need to check this out.

It's EVERY app, including Finder, Outlook, Chrome, Safari, etc. - there is no need to write to a default folder for those apps.

Fair enough. I'm sorry. I'll reconsider. I think I've seen this before on my own Mac. I'm trying to recall the solution.

Aha! I remember. The buttons are greyed out but they still work. At least they do for me. All my apps have the same problem as yours, but the buttons still work. Please verify that the problem isn't simply that the buttons are actually just greyed out. My buttons are greyed out too, right now, but they still function. I can't remember why this is the case.

Yes, mine are grayed out, and most do work. Only Command-n doesn't work!

Okay. I guess this could be caused by CMD-N being assigned a keyboard shortcut in the System Settings app. When you wrote "There are also no built in keyboard shortcuts that have taken over Command n" were you referring to KM shortcuts or macOS shortcuts?

I see lots of people online on the Apple support forums complaining about this, so that suggests it's not a KM issue.

Do you use macOS "Spaces"? Some people report that interferes with CMD-N. Another person (from 2005) reported that a PRAM reset solved his CMD-N problem.