Newbie Trying to connect mini keyboard USB Device to work with KM

You are spot on, that was the problem. Just got off with Adobe tech guy and somehow the prefs were the problem. But humpty dumpty is back in action. I think I'll give it another try tomorrow. Inching closer. I cannot thank all of you enough. You've been so generous! We'll see what happens. Hopefully it's not corrupting the prefs and it was maybe just a coincidence? should I dare try it again?

1 Like

Things are looking a lot more hopeful here, many thanks to all!!

I've programmed most of the keys, however a few are problematic. The hitch I'm encountering is sometimes Lightroom seems to ignore the actual keystroke it was originally intended for and only trigger the macro, and sometimes it triggers both the macro and the original use. Most of the time this is not a problem, but one of the keys I had to use the "end" key position on the extended keyboard, so now the macro works but it also triggers putting me at the end of the row of thumbnails.

Is there a way to make KM have an exclusive for that key and ignore it's origninal use? I believe we did touch on this, but is went over my head a bit. Attached is a screen grab of how I've set it up.

Wow, you managed to get the device to accept USB key triggers. That's a nice surprise. Most of this thread was predicated on the claim that you couldn't get USB triggers to work with that device. Using USB key triggers is what I wanted you to do back in my first post on this thread. Good work.

Now that you've got it to work, I'm not sure if it's clear to you, but this method of triggering does not "consume" the key, which means that in addition to KM detecting it, your active app will also detect it. That's what you say is happening. The simplest way to stop that is to enter the application and tell it to stop responding to that key. I just googled it, and Lightroom has a feature called "Edit Shortcuts" which is most likely where you need to go to stop it from responding to that key.

So my suggestion is that you disable Lightroom's shortcut that is making it respond to that key. That way KM will have exclusive ownership of that USB key trigger.

THANKS!!! :pray: :pray:

@Airy's suggestion of changing Lightroom's shortcuts is quick and easy -- but note that the keystrokes still get passed to Lightroom so you may end up with a lot of annoying boops from "You pressed a key that I don't understand".

You use a "hot key trigger". But remember that a "programmed" A on your secondary keyboard is the same as an A on your main one.

OMG Somehow I did something where the mouse everytime it's clicked jumps to a spot on the screen. Now my mouse is unusable basically. Feeling extremely foolish right now. uggghhh

I'm searching around but have not found anything to remedy this yet

Well, you did want those keys to click on the button, so you used a Move and Click mouse action. That's probably what's causing your mouse to move. If you want it to move BACK that's another step, or at least an option you have to select. If you click on the cogwheel of the Click Mouse action, you will see an option called "Restore Mouse Position". Usually that option puts the mouse back.

I'm sorry for not anticipating that that's what you wanted to do.

The situation is that I no longer have any control of my mouse, so I'm unable to do anything that requires mouse movement. If I click the mouse now it doesn't do anything except jump to another spot on the screen. Basically my mouse is unable to do what it's supposed to do. I seem to have backed into a terrible corner here. I'm using my other computer to type these messages.

If your Engine is grabbing your mouse, preventing you from using your mouse, you should disable the Engine. Depending upon how much control you have lost, you might still be able to disable the engine using the KM System Menu option.

Another way to end the engine is to open a terminal window, and enter a command to end the Engine, but if you can't even open a terminal window, then you won't be able to do this. If you can open a terminal window, then you can probably end the Engine using the KM System Menu option called "Quit KM Engine".

In either case, you should probably create a macro that terminates the Engine so that you don't get stuck in this position again. We can discuss this after you've got control of your Mac again.

Let's see if anyone else has another idea for getting control of your Mac again. If not, you may have to cold-reboot it.

Try Shift-Command-/ to activate the menu in keyboard mode, then the arrow keys to move over to File, then type Q to jump down to Quit Engine.


For that to work, I think the KM Editor has to be the active app, right?

It does, but assuming his keyboard works, Command-Tab should get there if he left it running. If he didn't, Command-Space then typing Keyboard Maestro will launch it.


There's a high chance that's because you've inadvertently set one of your "USB Device Key" triggered macros to act on a mouse-click (actually quite easy to do).

If you haven't got a different mouse around that you can use, try:

  1. Command-tabbing to get the KM Editor to the front
  2. Right-clicking on the probable macro group
  3. Using down-arrow then Return to select "Disable Macro Group" and then disable

Rinse and repeat until you get your mouse back to normal, then go through the macros in the last Group you disabled to find the culprit.

If the KM Editor isn't running then Command-tab to Finder, Shift-Command-A to go to the Applications folder, type as much as you need of "Keyboard Maestro" to select the KM app, Command-O to open, then do the above.

(You may guess that I've had to do similar a few times now :wink: )

OK I'm breathing again whew. The mouse is back to life. I found the culprit macro and I changed the key to something else and it's working. My g-d thank you everyone, just can't thank you enough. May kindness come back to you a thousand fold in everything good!

You probably should create a global macro to "cancel all macros" and since you move the mouse a lot, you probably should also create a macro to terminate the engine.

You should assign these two macros to two hotkeys that you don't usually use. I use SHIFT-F19 for one of them.