Next Track macro stopped working

Very long term KM user here. One of my oldest and most used macros has stopped working: Next Track in the Music app in Catalina. I tried changing the hotkey in case something else started eating it, but that didn't help. Also it's not the keystroke failing, because it does have an effect -- of stopping the track. Instant quiet and I have to go back to the app to click play. The usual "start playing a track KM macro won't work after the Next Track stops playing. It works within the KM editor if I try "try action" from the gear menu. Fails in Apple Music as well as playing tracks in my own library. Anyone else? Workaround?

Oh I should say I'm on 10.15.5. Also I tried re-creating this from scratch, and it still didn't work.

And now it has started working again. Weird.

And now it has stopped working again.

@jlehet - How long have you been on Catalina? Is your macro in a global group? Also, please post your macro so we can have a look.


On Catalina since late '19. The macro is in Global Macro Group indeed. I uploaded it to the forum from the KM editor, not sure where it went (I'm new to the forum, old to KM). Nothing much to it. I've restarted the Music app; maybe I should reboot the mac. It's been up for 10 days. Usually I don't reboot for at least 20 days or so on average.