No macros will run

Keyboard Maestro has stopped executing any macros. In fact, a lot of the related functions are also not working: e.g., clicking ‘Check for Update…’ in the Editor app does nothing; the KBM icon no longer loads in the system menubar. I was able to import a single macro into the library and that import did appear to work. However, the imported macro did not run, either live or in ‘Try’ mode.

This began days ago with a "Secure Input Is Enabled” message from KBM that was displayed one time. Based on that alert, I ran one of the scripts posted here, but the returned result was ‘false’ (no offending app was identified).

This state of KBM has persisted across numerous system restarts. I trashed and recreated the plist file, without effect. I even updated my OS to High Sierra. The status of my macros not executing continues.

Contacting the Apple Support Community, I was given the suggestion to run EtreCheck. I performed a system restart, ensured nothing was running, and then ran EtreCheck. The last part of the report reported this:

Diagnostics Events (last 3 days for minor events): ⓘ
2018-02-12 08:18:24 Keyboard Maestro6.app Crash [Open]
Cause: dyld: launch, loading dependent libraries

I can provide the full test of the report if that’s helpful.

Any suggestions?

I am running KM 6.4.8

Sounds like something is quite messed up in your system or in your Keyboard Maestro installation. I would:

  • Remove any reference to Keyboard Maestro from the Login Items (System Preferences, Users & Groups).
  • Restart
  • Download a fresh copy of Keyboard Maestro 6.4.8 from https://download.stairways.com
  • Move it to the Applications folder (using the Finder) and overwrite the existing Keyboard Maestro.app.
  • Launch it. Verify whether the Keyboard Maestro Engine launches (the Keyboard Maestro icon should appear in the menu bar).

See what happens from there.

That worked. Thanks!